Unable to add folder to workspace in Dev tools



  • Yay!!! I can now dock the dev tools :)
    But i am unable to add the folder to workspace :(. I am not sure if it is a known issue :|



  • @ranaus This is known for quite some time and was already reported. But you can add the folder to your workspace manually:

    • Close Vivaldi
    • Open %LOCALAPPDATA%\Vivaldi\User Data\Default\Preferences in a text editor
    • Search for "file_system_paths"
    • It should look like this: "file_system_paths":{}
    • You can add your path to that map as a key with a null value, e.g.: "file_system_paths":{"C:\\MyProjects\\webapp\\":null}
    • If you now open Vivaldi, your path is available in the workspace

  • Moderator

    Yes, old bug. VB-29664 "Developer Tools - add folder to Sources workspace fails"



  • @tobias-liefke said in Unable to add folder to workspace in Dev tools:

    %LOCALAPPDATA%\Vivaldi\User Data\Default\Preferences

    Thanks for the hint/workaround.. but..

    The file above did not contain the "file_system_paths" entry/object on my installation. Adding it manually does not seem to make a difference. The "Settings -> Workspaces" area still does not list paths or allows me to add mappings.

    I double checked what the entry would look like in chrome, and it's absolutely identical to what I put manually into Vivaldi's "Preferences" file.

    Any idea? I really would like to stick to Vivaldi for development purposes. o) Thx!



  • This bug is still around in 1.15 and the workaround noted in the post above does not work. Any ideas for how to work around this issue?



  • @tbone-15 @cupanoodle

    Ran into this issue today, also tried the fix and it did not work. However, I did a bit of sleuthing* and it looks like the setting name is devtools.file_system_paths, not just file_system_paths. This means that if file_system_paths doesn't exist, you need to make sure you add it not in the outer level, but under the devtools dictionary.

    Here are the steps from above, modified appropriately:

    • Close Vivaldi
    • Open %LOCALAPPDATA%\Vivaldi\User Data\Default\Preferences in a text editor
    • Search for "file_system_paths". It should look like this: "file_system_paths":{}.
    • If it doesn't exist:
      • Search for "devtools".
      • It should look like this: "devtools":{โ€ฆ
      • Add "file_system_paths":{}, right after the {. Make sure you add the comma in the right place.
    • You can add your path to that map as a key with a null value, e.g.: "file_system_paths":{"C:\\MyProjects\\webapp\\":null}
    • If you now open Vivaldi, your path is available in the workspace

    * How I found the namespaced setting name:
    1. https://www.google.com/search?q=chrome "file_system_paths"
    2. https://github.com/electron/electron/blob/master/chromium_src/chrome/common/pref_names.cc


    HOWEVER, after adding the folder, I don't see the "Map to network/local resource" option. So I don't think this solves the entire problem :(


  • Moderator

    Adding folder to workspace in Developer Tools works in 1.16.1221.3 on Windows 10.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.