change location of userprofile



  • In our network we use roaming profiles. Actually this does not work with Vivaldi because the standard location of the vivaldi userprofile is not AppData\Roaming. It is AppData\Local.
    Is there a possibility for me to change the standard location to AppData\Roaming?



  • Yep.

    First you'll want to move your existing profile to the relevant roaming directory.
    Then, you'll need to modify the shortcut that launches Vivaldi to something like %LOCALAPPDATA%\Vivaldi\Application\vivaldi.exe --user-data-dir=%APPDATA%\directory_of_profile

    Here, %appdata% points to /roaming
    You may also need to move the vivaldi.exe installation directory to something more permanent, that works across machines.

    Also, be aware that the profile will end up containing a large amount of cache files that will end up having to be moved around the /roaming directory, so you may wish to keep that as local. Unfortunately, I can't remember the exact flag to change the cache directory.



  • There could also be a problem with Extensions and Passwords :
    If I remember correctly, Passwords and Extensions use the UID of the user to cipher their contents, and the UID includes the machine ID.

    I don't know about roaming profiles though, is the UID preserved between machines ?
    If not, you will lose all saved passwords and extensions (best case, unreadable, worst case, data corruption) when the profile roams among the network.
    If it does stay the same, you should be OK with the command flag @LonM mentioned.

    In addition, it seems the cache flag for Chromium based browsers is --disk-cache-dir.



  • Thank you very much for your help.

    My link to launch Vivaldi is now:

    "C:\Program Files (x86)\Vivaldi\Application\vivaldi.exe" --user-data-dir="%APPDATA%\Vivaldi\User Data" --disk-cache-dir="%LOCALAPPDATA%\Vivaldi\User Data"

    This works very well.



  • Oh, there is a little problem:
    double-clicking a html-file in explorer launches Vivaldi without those flags.
    Is there any solution to prevent this behavior?



  • @vivazula you probably have to manually edit your registry
    for example:

    [HKEY_CLASSES_ROOT\VivaldiHTM\shell\open\command]
    @=""C:\Program Files\Vivaldi\Application\vivaldi.exe" -- "%1""

    you'll have to add your additional parameters before --



  • @iAN-CooG said in change location of userprofile:

    @=""C:\Program Files\Vivaldi\Application\vivaldi.exe" -- "%1""

    With this I can't open html-files any longer. He always says "you have no permissions to access this folder".



  • erhm, you have to put there YOUR vivaldi path, of course



  • @iAN-CooG

    @=""C:\Program Files (x86)\Vivaldi\Application\vivaldi.exe" --user-data-dir="%APPDATA%\Vivaldi\User Data" --disk-cache-dir="%LOCALAPPDATA%\Vivaldi\User Data" -- "%1""

    It ist the folder of the html-files which he says "you have no permissions ..."



Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.