Mouse double backward / forward

  • Hello!
    Disclaimer: I've searched through the community forums, and haven't found anything helpful. The only topic that is similar is this one: and it has a fix of driver reinstall. However it didn't help me in my case, I've tried that.

    The issue: when I am browsing using Vivaldi, when I press mouse forward/backward buttons, it jumps two history records in either direction, instead of one. None of the other browsers and programs in general show this behavior - it was the first time I encounter something like that.

    Technical details:
    OS: Win10x64 Pro, 15063.413
    Mouse: A4Tech F7

    Any help would be really appreciated, I like Vivaldi a lot, it has a lot of useful features (oh my god normal link text selection), but this double-backward/forward jump is like an annoying little chip in otherwise polished experience :)

  • Moderator

    @cxshel Could be a dirty or loose switch or contact in your mouse, and Vivaldi having a zero delay on detection of clicks, while other browsers have a delay (like 5 ms) perhaps.

  • Oh, an interesting idea. Is there any way I could change it to test this theory? The mouse is indeed in somewhat rough shape (but serves me good so far)

  • Moderator

    @cxshel Under a similar situation, the way I tested it was to try another mouse.

  • @cxshel I've just fixed this. I have a cheap a4tech mouse that comes with software that lets you reassign buttons. So as it turns out, Vivaldi uses mouse's "back" to "rewind" instead of just going back. So what I did is I reassigned my mouse's "back" and "forward" keys to "alt+left" and "alt+right" respectively, which fixed the issue.

  • Happens to me too. My mouse is fine.
    Reassigning the buttons would create a really ridiculous problem since then you could no longer use the backward and forward commands in any other program, which I'm sure most of us need....

  • @Ayespy said in Mouse double backward / forward:

    @cxshel Could be a dirty or loose switch or contact in your mouse, and Vivaldi having a zero delay on detection of clicks, while other browsers have a delay (like 5 ms) perhaps.

    I don't think this is quite the culprit. They're not the first ones it seems with this issue. My mouse is tightly connected & in great condition, as well as clean. It registers my back and forward as double every single time. :( In fact, it has ever since I first installed it. I wish there was a way to assign mouse buttons to actions, like you can do for keyboard shortcuts. I love this feature in things like video players. It would be ridiculously helpful in this context as well.

  • Interesting! Thanks a lot guys for replies. I would also be glad to see mouse setup options menu!

  • Any updates on this issue? It is single-handedly preventing me from using Vivaldi. If it's of any help, hitting the back button as configured on my elan touchpad (three finger press) registers as nothing on but triggers multiple go back actions. This behavior is unlike Google Chrome or indeed any other program I've used. Windows 10 64bit, Vivaldi 32bit.

  • Moderator

    @cxshel There are some touchpad issues, but the problem is different to mouse button issues.

    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    if you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a link to a testpage where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.