V. does not respect text boxes



  • I find this quite often. Not on all sites, but, for instance, on one site I frequent, when I'm in a composition box and hit Ctrl-left/right to navigate around for editing purposes, V. will interpret that as a Back/Forward page navigation command, and I exit the page. Luckily the site memorizes the draft, so I haven't lost any work so far. But not all sites offer that protection.

    I don't expect anyone to sign up to test this, but here is a sample site where I routinely experience the problem: https://www.christianforums.com



  • @paul1149
    You have 2 ways to work around that.

    1. Use this before typing into input box.
      0_1497978016803_maim-2017-06-20_23-58-15.png

    or

    1. Delete/Change Ctrl+right and Ctrl-left
      0_1497978051800_maim-2017-06-20_23-58-21.png


  • Thanks very much, @dLeon . #2 looks like it will be fine. I'm used to only Alt-left/right anyway, and don't know how Ctrl-left was set (there was no Ctrl-right set). Should solve it. Thanks.



  • @dLeon Unfortunately, the BackSpace key does it also, though not all the time, and I don't want to unmap it



  • @paul1149
    Yeah.
    There's already some issue raised for Backspace key alone.
    Requests & bug reports for Vivaldi shortcuts to not effect input boxes or cloud editor already flying in.



  • @dLeon Ok. Good. Kinda important.

    Thanks. BW.



  • BTW, one fact that might help in finding a solution: this happens most to me on a xenforo forum site. I know they have a lot of javascript going on.



  • @paul1149 said in V. does not respect text boxes:

    xenforo

    as is said: the bug is known and was reported.



  • It has also happened to me many times, but it seems almost random, & often not repeatable. Most recently it occurred to me several times last night when i was composing a post on the openSUSE Forum site. The most common keys that seem to trigger it are 1, 2, 4, 5 [which i'm not willing to disable or change in Settings, given these are important tab navigation keys for me when i am not in a text box]. Also sometimes W, sometimes Z. When these random jumps occur they give me apoplexy... sometimes i can recover my text, but sometimes it is lost.



  • @Steffie said in V. does not respect text boxes:

    openSUSE Forum

    That doesn't look like Xenforo. The one saving grace about the situation is that xenforo has an excellent post-in-process saving mechanism, which lags only about a second behind your typing. So I've never lost anything. But this is one annoying bug. I wonder if double-clicking in the text box would help. Once I nav back to the page it never happens again while I'm composing.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.