v1.11Betaでタブが再度フォーカスされた時に、ページの下部が隠れてしまう問題



  • 再現手順

    1. タブを2つ以上表示して任意のサイトを表示(あらかじめ一番下までスクロールしておくと症状がわかりやすいです)
    2. タブを一旦、もう片方に切り替えて、ふたたび元のタブに戻る
    3. ページの下部が隠れており、スクロールしても表示できない(※)


    ウインドウのサイズよりも、実際の表示領域が大きくなってしまい、下にスクロールしきってもウインドウに表示されない部分がある。

    Vivaldi 1.11.880.3
    macO 10.12.5

    暫定回避方法

    なにかしらウインドウサイズ(表示領域)を変えると元に戻ります。
    (自分はステータスバーやサイドバーを一旦表示したりして表示領域を変えて対応しています)


  • Vivaldi Team

    @nibushibu ご報告頂き、誠にありがとうございます。同じOSとVivaldiのバージョンで試しましたが、再現できませんでした。お手数をおかけ致しますが、現象発生時の動画などをご共有頂くことは可能でしょうか。よろしくお願い致します。



  • ご返信ありがとうございます。

    すみません、Vivaldiを再起動したところ問題が再現しなくなりました。
    一時的な問題なのかもしれません。確認が不十分で失礼しました。

    もし再発し、確実な再現手順がわかったら改めてご報告いたします。



  • 再現手順がまだはっきりしないのですが、症状が再度発生したので、ひとまずスクリーンキャプチャを以下にアップしました。

    https://drive.google.com/open?id=0B2d99S8YSMv4elVidTFydlMwTE0

    タブを切り替えた直後、ページの下部がスクロールしきれず隠れてしまう部分があり、
    ステータスバーを一旦非表示んするなどして表示領域を変更すると、その後は、最後までスクロールできるようになります。

    いまのところ、Macの機能でVivaldiのウインドウをフルスクリーン化している時のみ再現します。
    デスクトップにウインドウがある状態では再現せず、またMacのフルスクリーン化していたとしても、Vivaldiのフルスクリーン機能が有効の状態(タブやアドレスバーなどもすべて隠れた状態)では再現しません。



  • ページの下部と書きましたが、正確には、左右(右側)も隠れるようです。
    下部と同じく、表示領域のサイズを変えると、リフレッシュしたように元に戻ります。

    隠れている部分のサイズを見ると、

    • 下部はタブ・アドレスバー・スタータスバーの高さの合計、
    • 右はサイドバーの高さ
      に相当するサイズが、それぞれ表示領域からはみ出てしまっている(隠れてしまっている)ようです。


  • バラバラとすみません、
    問題が再現するのはタブ単位で、あるタブで問題が再現している最中も、
    別のタブでは大丈夫な場合もあります。

    なにかの操作をきっかけに問題が再現するようになると、再起動しても同じタブでは問題が継続する場合もあるようです。

    確実な再現手順がまだわからず、バラバラと報告ですみません。
    再現手順がはっきりしたら、改めてご報告いたします。


  • Vivaldi Team

    @nibushibu 早速ご対応頂き、ありがとうございます。Macで全画面表示を使用した際、こちらで再現できました。ただちに報告し、優先的に修正致します。今しばらくご不便をおかけいたしますが、よろしくお願い致します。



  • @Takaaki 早々にご確認いただきありがとうございます!
    よろしくおねがいいたします :smile:



  • Vivaldi社の方で再現されたとの事なので、何ですが… この不具合、私の環境(macOS Sierra 10.12.5、Snapshot 1.11.880.3)でも試してみましたが、私の環境では、再現しませんでした…。キャプチャ動画と同じサイトでも試してみましたが、それでも再現せず…。なので、再現条件が結構シビアなのかなぁ〜と。(^^;


  • Vivaldi Team

    @kyu3a ご確認頂き、ありがとうございます。私は同環境で、全画面表示使用時に100%再現できます。。。なお、すでに修正に動いております。進捗のご報告まで。



Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.