Trying to change theme - reverts to standard theme



  • I copied the Dark theme because I want to edit it. But whenever I select it and do anything to it (ie. change the accent colour) or similar, it reverts to the Light default standard theme. Happens every time now, can't seem to have run into this before. Very annoying.

    Version 1.10.867.38 (Stable channel) (64-bit).


  • Moderator

    @Nebu Do you click on the "edit pen" to save your changes after you edit a theme? It's working here...



  • I believe the changes are being saved automatically.

    As soon as you click the pen when you are on an inbuilt theme, a new theme is being created and saved. If you wanna make another version of a custom theme select it and then click the plus button to copy it. No further action is needed, and your new theme should stay selected and activated.

    So I believe your problem is that you have scheduled themes enabled, and this makes Vivaldi switch to the light theme, which is scheduled at the moment. Just disable scheduled themes and everything will work out as expected.



  • @Ayespy said in Trying to change theme - reverts to standard theme:

    @Nebu Do you click on the "edit pen" to save your changes after you edit a theme? It's working here...

    Yes. I click the edit pen and a copy is made and I try to edit it. The moment I change a colour or something it jumps back to the default light theme. Making changes is thus a pain in the backside.

    @luetage said in Trying to change theme - reverts to standard theme:

    I believe the changes are being saved automatically.

    As soon as you click the pen when you are on an inbuilt theme, a new theme is being created and saved. If you wanna make another version of a custom theme select it and then click the plus button to copy it. No further action is needed, and your new theme should stay selected and activated.

    The theme I'm messing with is already copied and new. It doesn't stay selected and activated as it should.

    So I believe your problem is that you have scheduled themes enabled, and this makes Vivaldi switch to the light theme, which is scheduled at the moment. Just disable scheduled themes and everything will work out as expected.

    You're actually perfectly right. Disabling this (I didn't know I had it activated) solved my issue. Thanks! :D


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.