vivaldi bug in fonts


  • Vivaldi Translator

    wanted to try some other fonts and changed they in the settings page...now i cant revert back...as you can see from the screen fonts are right but they are all messed up...
    for the record i'm using fedora workstation 25...0_1497782511218_Schermata da 2017-06-18 12-40-37.png



  • @luca247
    I assume you're not playing with user.css (stylesheet) to change Vivaldi UI look.
    OR... playing/changing font in your DE/WM control panel. Both are different story.

    Did you try to at least change those Font option drop down.
    At least in safe side:

    Standard : Sans or Serif
    Sans-serif: Sans
    Serif: Serif
    Monospaced: Monospace
    Cursive: [1] 
    Fantasia: [1]
    

    Restart Vivaldi.

    Sans, Serif & Monospace are standard default for Linux system. They just link to real font.

    [1] You'll need these types of fonts to actually make use of them. If Windows Core Font package installed the entry will be Cursive: Impact & Fantasia: Comic Sans MS.


  • Vivaldi Translator

    here's what i've done, i just changed fonts in the settings page...default were the abyssinica sil and monospace and i switched them to cantarell which is fedora default, i didn't like the result so i switched back, but fonts still stay the same...no matter which font i choose they stay the same...i installed vivaldi stable to see which fonts were using and it's using abyssinica sil and monospace, and fonts are correctly displayed...



  • @luca247
    Weird.
    Doesn't happen or never happen to me even if I change font to most weird font such Mathematic fonts.

    Could you give screenshot when it does look right when "abyssinica sil" was set.
    I check around & found that "abyssinica sil" font is in fact Serif font (ex: http://www.fontspace.com/sil-international/abyssinica-sil).

    I ask because your first screenshot is shown in Serif font all over the place.

    If you're not;

    1. Using custom CSS
    2. Playing with your DE/WM/System default font settings.
    3. Obviously, Vivaldi font settings not really effect much anything.

    I'm not really have a clue what happen there.

    Worst test scenario, clean Vivaldi profile.

    Default Vivaldi UI font for Linux soft coded in common.css

    #browser.linux,
    #browser.linux + div,
    #browser.linux + div + div,
    #browser.linux button,
    #browser.linux input,
    #browser.linux select,
    #browser.linux textarea {
      font-family: Ubuntu, sans-serif;
    

    Each OS has their own settings.
    Here, for Linux default is Ubuntu font if fail, our default sans-serif


  • Vivaldi Translator

    here's the screens :) ...this is vivaldi stable fresh installed and it looks right...0_1497793198291_Schermata da 2017-06-18 15-38-52.png

    this is vivaldi latest snap...0_1497793221097_Schermata da 2017-06-18 15-39-21.png



  • That's weird indeed.
    From your screenshot I could take a picture "What Vivaldi done there (last summer?)".

    In context of Vivaldi UI;

    • By default, Vivaldi use a Sans font on the new profile. It does not even care the font setting was set with Serif font, as long we do not touch it.
      It doesn't matter anyway. That settings was only for Webpage to begin with.
    • For some reason, in 1st screenshot, it choose a different Sans from your (probably) default Sans font. Your DE panel was using a different Sans there.
      And Vivaldi should only use Sans fonts (per default CSS) for its UI. How could Vivaldi locked with Serif fonts? :confused:

    If you could reproduce it with clean profile (no extensions, no other settings touched), then report bug it.

    I really got no idea what's happening.
    I tried to reproduce it;

    • By changing fonts to anything.
    • Set uBlock0 to not except remote font. I see you're using it in your 2nd screenshot.

    No dice.

    On me, except using my personal sytlesheet to change UI font, Vivaldi just use Ubuntu font because I installed it. If I remove it, Vivaldi use my DejaVu Sans font because it's my default Sans font.


  • Vivaldi Translator

    well i could solve everything with a clean reinstall but didn't want to input my passwords all over again...anyway, how to start a new profile? :)



  • @luca247 said in vivaldi bug in fonts:

    how to start a new profile?

    Read through this article
    https://help.vivaldi.com/article/full-reset-of-vivaldi/


  • Vivaldi Translator

    thanks...that's solved my issue...even if it would have been better to know why :)



  • @luca247
    For all the trouble, Password currently still easier to move around.

    1. Enable chrome://flags/#password-import-export. Restart Vivaldi.
    2. Visit vivaldi://chrome/settings/passwords (old look). Export/Import to/from CSV will be there.

    Note:
    Don't use chrome://settings/passwords. In new Material Design (new look), Chromium kick out export/import button.


  • Vivaldi Translator

    thanks...will remember that...


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.