Can't install Vivaldi on Elementary



  • Hi there, i'm kinda new on linux so i'm maybe doing it wrong, but it seem i can't install Vivaldi Browser on my computer because of some dependencies i guess, so i looked up a but on the internet and i found that i had to use the "sudo apt-get -f install " command, but it doesn't change anything ... can anybody help ?
    Thanks



  • If you had downloaded the *.deb package from the Vivaldi website, the command I use to install it to a debian/Ubuntu distro is this:

    dpkg -i packagename.deb

    Remember to replace packagename with the actual name of the file.



  • Thanks for the answer, but i already did this and i got an error like :

    $ sudo dpkg -i vivaldi-stable_1.0.435.42-1_amd64.deb
    (Reading database ... 154846 files and directories currently installed.)
    Preparing to unpack vivaldi-stable_1.0.435.42-1_amd64.deb ...
    Unpacking vivaldi-stable (1.0.435.42-1) over (1.0.435.42-1) ...
    dpkg: dependency problems prevent configuration of vivaldi-stable:
    vivaldi-stable depends on gconf-service; however:
    Package gconf-service is not installed.
    vivaldi-stable depends on libgconf-2-4 (>= 2.31.1); however:
    Package libgconf-2-4 is not installed.
    vivaldi-stable depends on libappindicator1; however:
    Package libappindicator1 is not installed.

    dpkg: error processing package vivaldi-stable (--install):
    dependency problems - leaving unconfigured
    Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
    Processing triggers for desktop-file-utils (0.22-1ubuntu5.1+elementary2~ubuntu0.4.1) ...
    Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
    Rebuilding /usr/share/applications/bamf-2.index...
    Processing triggers for mime-support (3.59ubuntu1) ...
    Errors were encountered while processing:
    vivaldi-stable

    Btw looks like it's doing it for each and every packages i want to install, whether it is from apt install pkgname
    or dpkg -i packagename.deb.


  • Vivaldi Translator

    @El_Mouetto
    The error messages is because dpkg -i doesn't install dependencies for Vivaldi.

    If after sudo dpkg -i …deb you could see Vivaldi does unpacked in /opt/vivaldi(-snapshot), do sudo apt-get -f install.
    The last one will install missing dependencies for Vivaldi. Assuming your distro repository does have all dependencies.

    --
    Tips:
    If you want to try to install DEB package;
    I suggest to install package gdebi (Gnome UI) or gdebi-kde (KDE UI) or gdebi-core (command line).
    gdebi could help install *.deb & resolve any dependencies.

    So next time, you could just do;
    sudo gdebi ...deb or
    sudo gdebi-gtk ...deb or
    sudo gdebi-kde ...deb
    And let it resolve all.

    apt-get -f... is (one dangerous way) for installing from internet if repositories already registered in sources.list.
    After Vivaldi installed, its installer script will register Vivaldi repository server.



  • @El_Mouetto said in Can't install Vivaldi on Elementary:

    vivaldi-stable_1.0.435.42-1_amd64.deb

    Hi, Vivaldi 1.0.435 is very old we are at 1.10!

    Cheers, mib


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.