vivaldi broken on windows 10 surface pro 4 since 16-jun update



  • subject says it. until today's update, I was happily able to use vivaldi for everything, google apps etc etc. since the update that went in today, it just hangs up the entire surface pro 4. can't close tabs, can't switch tabs, after a few seconds of use. i think there's a bit of the pen issue reported elsewhere also but essentially the machine becomes unusable. I'm back to chrome for now but would much prefer not to be.



  • I created an account just to emphasize that this is indeed a problem, I have been having this happen as well. I've been having to use Microsoft Edge in the meantime.



  • To confirm: 1.10 is broken on windows 10, surface pro 4. I've uninstalled it and gone back to 1.9.818.22 and that is working. The breakage is very complete; here are more details:

    Main symptom: browser hangs up, in all respects, or is taking many minutes to do anything (to the point where you give up and try something else, which also doesn't work). This freeze-up happens within 20 seconds of starting it up. Initially you may be able to switch tabs etc. but that is all over very quickly. End state: it is taking up more than 25% of the CPU even with only one tab open, and you can't even close the window without resorting to the task manager.

    The rest of machine is ok (sorry I had thought that wasn't the case in my original posting, but I now see that I can switch to other apps well enough)

    Possibly related: in the ten-second period where you may be able to do something, touch with pen doesn't work - e.g. speed dial folders can be closed on the x but not opened by clicking the body of the folder. touch with finger works ok.

    right click task bar icon and close window - doesn't
    click close button on window - doesn't

    I removed all extensions and restarted, same thing.

    I started a new window with only one tab, in case it was the number of tabs I had open (no more than 15). it wasn't. same thing.

    Uninstalling and grabbing 1.9.818.22 has got me a functional browser again. So, something is seriously wrong with 1.10 on this platform.



  • 1.11 is the same. still unusable on surface pro 4. bit more info: seems related to using the pen. if you browse using finger swipes, it seems to survive. the second you use the pen (for anything, as far as I can see) it hangs up.

    Staying at 1.9, obviously.



  • @aach1 Did you filed a bugreport already? You can do this here



  • @zaibon hi - yes, thanks I did file this one.



  • I have a surface pro 3 and I'm getting all the same issues. I hope this gets fixed soon!



  • Still completely broken as of 1.11.890.4. More or less ok until you use the Surface pen, then hangs up completely. I only tried this one because I saw mention of a Chromium update, but clearly that's not the problem (or it is, and it's been the same problem since 1.10).



  • @cardaraj I now have a copy of the 1.9.818.22 install file on my desktop, and each time I try and fail with a new snapshot I just uninstall it and install from that one. since you have the option of not deleting browser data when you uninstall, you get all your tabs back when you run 1.9. Better than Edge, though I have to say that with every day that passes I'm warming to the latter...



  • Still broken after today's update.



  • Tried 1.11.901.3 today, having noticed that it includes an update to Chromium. No joy, still broken, though this time it took a few minutes to lock up totally, chewing CPU into the bargain. 1.9.818.22 is still fine on the same machine.



  • @aach1 It's not easier to install the new snapshot as standalone? So you don't mess with the working 1.9 every time and you know when a newer version is working for your device ;)



  • @Hadden89 hi - never found myself in this situation before (I've tended to stick to stable releases) so didn't even know that was a possibility. Thanks for the tip and I'll have a look at how to do that.



  • Yes, I've found this as well. I've been using Vivaldi as my default browser for a while now, and mainly use my Surface Pro 4 as a laptop with keyboard attached and often with a wireless mouse. Yesterday I wanted to use it purely as a tablet whilst enjoying some serious sofa time. It was difficult, if not impossible to select items and tabs in Vivaldi. To begin with I thought it was a pen problem and then realised the only app affected was Vivaldi. In the end I was forced to switch to Edge.


  • Moderator

    Al i can say repeating: send bug reports, send bug reports, send bug reports, send bug reports, …

    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    if you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a link to a testpage where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!




  • @Gwen-Dragon I did indeed file a bug report - I mentioned that in the thread but I see I didn't give the number, so apologies for that. It is VB-29544. Contains all the info requested, how to reproduce etc. This doesn't seem to be limited to pro 4, judging by one or two responses in this thread, but it does seem to be limited to pens.



  • @aach1

    @aach1 said in vivaldi broken on windows 10 surface pro 4 since 16-jun update:

    I'll have a look at how to do that.

    You can install vivaldi (regardless of snapshot or stable) as standalone by clicking on "Advanced" in the install menu --> open the dropdown menu that says "installation type" and select "Install as Standalone" --> select a place where vivaldi should be installed (you can choose whatever you like but I highly recommend not to choose any folder that might interfere with your current "normal" install - just to make sure that nothing gets messed up) --> install.



  • @zaibon thanks for that. It's not very well documented, if I'm not missing something.



  • @aach1 Latest stable release (1.11) does not work on Surface pro 4 (and, judging by other responses here) other pen-based systems. Symptoms remain the same for me at least - a minute or two of reasonable use, then locks up completely and rails the CPU use.

    I'm sure I'm not alone in wondering what changed between 1.9 (which still works) and 1.10++ (which don't). Any info welcome.



  • Just to note that this is known to be a Chromium bug. Came up in an unrelated thread.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.