Проблема с вопроизведением видео



  • В общем, возникает довольно странный баг с вопроизведением видео (mkv) на googledrive, в частности бесконечная загрузка. Если же видео начнёт нормально воспроизводиться, прыжок по видео (к примеру, на минуты две вперёд) вызовет бесконечную загрузку (чёрный экран с "кружком" загрузки), но не факт, что не багнёт.

    Сия баг целиком и полностью отсутствует на стабильной версии вивы (1.9.818.50 32битка) и проявляется на всех последующих бета-версиях и новой стабильной версии. Youtube видео без проблем воспроизводится.

    Используется встроенная видеокарта от Intel, 32ух битная windows 7. Установлена последняя версия Adobe Flash Player 25.0.0.171.

    Судя по форуму, такая проблема вполне имеет место быть... https://forum.vivaldi.net/topic/16204/video-on-google-drive-will-not-start/7



  • От себя скажу что с выходом стабильной версии 1,10 данный баг есть. Ждет ответа от разработчиков, на что хотелось бы получить детали.


  • Vivaldi Team

    В BTS нет открытых репортов по данной проблеме. Был репорт в прошлом году - тестеры не смогли воспроизвести. Отправьте новый баг-репорт с подробным описанием, как воспроизвести.



  • @Shpankov спасибо за хоть какой-то ответ, но скажу что в деталях не смогу все прям точно описать на Английском так как знание его желают лучшего. Возможно я смогу описать тут? А от вас уже передать это разработчиком.



  • Воспроизвести сия баг очень просто - достаточно просто попробовать посмотреть видео (возможно влияет лишь на mkv...надо бы проверить и с другими) с googledrive - через секунд 5-20 просмотра, оно обязательно "сломается" на вечной загрузке (чёрный экран, "кружок" загрузки).

    Возможно, у каждого (у тех, у кого этот баг проявляется) он проявляется с разным "таймером" - к примеру, не через 5-20 секунд как у меня, а минута-две. Попытки "прыгнуть" по видео тоже приводят к "слому".



  • Почитав нам параллельную ветку на Английском с помощью переводчика, нашел у людей точно такую-же проблему с видео на сайтах. Я думаю теперь разработчики в курсе этого бага. Но для наглядности вот такую ошибку на одном сайте выдает плеер и только на Vivaldi.0_1498456450697_a918bf4a-727c-4b0c-9d59-59c3ce127d0f.jpg



  • Та же фигня на Вконтакте. 5-10-15 сек просмотра - и черный экран с полоской загрузки. причем до установки версии 1.10.867.46 (Stable channel) (64 бит) проблема была с абсолютно всеми видео на ВК. сейчас - какие-то воспроизводятся, какие-то нет (если надо - могу привести ссылки на конкретные видео и того и того "класса"). С ютубом таких проблем нет вообще - там все отлично играется.

    Попробовал через Яндекс-браузер 17.6.1.770 - там такой проблемы нет



  • Теста ради, снёс 1.9.818.50 (стабильную, без этого бага с видео) и установил последнюю версию (1.11.894.3) - баг есть и на этой последней версии.

    В общем, остаётся ждать, когда вылечат :)

    Warlock,

    попробуй поставить 1.9.818.50 (stable) эксперимента ради. Баги с видео возникают как то странно - у кого то на одной версии работает, а у кого то на ней же не работает.



  • Видео из ВКонтакте и Rutube, встроенное на других сайтат просто не воспроизводится. Баг присутствует уже с полгода.



  • Сегодня вышла новая версия стабильной Вивы...почитав список изменений и багфиксов, были замечены фиксы:

    "Media

    • [Windows] Audio stops playing after a while (VB-29546)
    • [Windows] Audio takes ages to start up (VB-29699)
    • [Windows] Support video/mpeg4 (VB-27459)
    • Proprietary media served with wrong unsupported mime type fails to play (VB-29504)
    • Permission dialogs for media and notification fails to open (VB-29799)"

    Из за этого, я решил загрузить новую версию Вивы (для чистоты эксперимента бета версию 1.11.917.35) и...

    Как минимум, видео с googledrive эти фиксы починили. Для интереса, зашёл на сайт со встроенным вк-видео - оно тоже работает (может сайт с этим видео попался такой, не уверен). Но сейчас ошибок с видео нет (по крайней мере пока что).

    Поэтому, все, у кого какие либо ошибки с воспроизведением видео, обновите Виву и проверьте работает ли у вас.



  • И с новой, 1.11.917.39 Stable, версией не работает встроенное видео из ВКонтакте и Rutube.
    Например http://ngs24.ru/news/more/50757491/ и http://dokonlin.ru/video/vselennaja-ostatsja-v-zhivyh-na-marse-th.html



  • @Petrovich72 ,
    Видео по первой ссылке
    alt text

    Видео по второй ссылке показало вот такие вот "прелести" (при этом, звук шёл и ползунок длительности работал и давал перемещаться по видео).
    alt text
    При этом, переход на исходную ссылку этого видео отправил кalt text

    Но видео по иной ссылке того же сайта вполне работает
    alt text
    (http://dokonlin.ru/video/so-stivenom-hokingom-1-serija-gde-my-gen.html)

    P.S
    Я был залогинен на вк, на рутубе акка нет.



  • Странно. А у меня просто чёрный прямоугольник вместо видео. Приходится смотреть в Опере или Firefox



  • Победил я это встроенное видео.
    Просто удалил и установил заново Vivaldi. У меня он был установлен с самого первого стабильного релиза и видимо где то при последних обновлениях закралась ошибка.



  • Вот и славно :) Интересно, решились ли и у остальных проблемы с видео.



  • Сегодня настраивал браузер и "вычислил" опытным путём почему не показывается встроенное видео из ВКонтакте и Rutube. Если в настройках приватности стоит галочка блокировать сторонние файлы сookie, то встроенное видео не показывает!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.