CNN videos



  • this is html5 video, i dont have flash installed at all. i installed support using this:
    https://gwendragon.de/repo/linux/vivaldi/vivaldi-libffmpeg-install.sh
    which seems to work everywhere, except cnn.com. on cnn.com it only plays sound and the video is blank. any ideas? it works with chrome proper of course.
    forgot to mention it's vivaldi 1.9.818.50 (Stable channel) (64-bit)



  • @marcosmobley Audio & video fine for me at that site, following your link. Ie, is not a generic Linux or Vivaldi problem. Something is wrong specifically with your local setup.

    BTW, you didn't do yourself any favours wrt helping others to help you. You told us absolutely nothing diagnostically useful... eg, Linux what, Vivaldi what, pc specs what?
    ...........................................................................................................................................................
    OS: Maui Linux 17.03 x64 Plasma 5.9.3;
    CPU: Quad core Intel Core i7-4790;
    GPU: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller;
    RAM: 32 GB.
    Vivaldi 1.10.867.3 (Official Build) dev (64-bit)

    ...........................................................................................................................................................

    EDIT, several hours later: OP edited their post to now include V info, so that part of my post is now redundant.


  • Vivaldi Translator

    @marcosmobley
    Same here, cherry pick random video around CNN, any just play in Vivaldi Stable or Snapshot.

    My blind shot:

    1. Close any CNN tabs, clear your cache & cookies. Revisit.
    2. If you use any extensions, disable all of them, do point 1. Revisit.
    3. Try clean Vivaldi profile.


  • @dLeon this is a fresh install on debian stretch 64-bit. vivaldi's therefore is also fresh and there aren't any extensions for me to disable. i tried clearing cache/cookies, but no go



  • @marcosmobley I run debian testing distribution and vivaldi-snapshot 1.9.804.3-1.

    To run some videos (netflix, amazon, cnn, yahoo), you need to install at least one of these two packages:

    • chromium-codecs-ffmpeg-extra
    • oxideqt-codecs-extra (vivaldi prefers this one, if available)

    These are not distributed by debian due to their open source licensing policy.

    I get them from ubuntu, with these changes to avoid other ubuntu packages from getting selected:

    • /etc/apt/sources.list (to get the ubuntu repository as a source of packages):
    # chromium-codecs-ffmpeg-extra from ubuntu to play H264 videos:
    deb http://archive.ubuntu.com/ubuntu devel-proposed universe
    deb http://archive.ubuntu.com/ubuntu devel          universe
    

    -/etc/apt/preferences.d/limitUbuntu.pref (to limit the ubuntu repository to just those two):

    Explanation: block all ubuntu packages
    Package: *
    Pin: origin "archive.ubuntu.com"
    Pin-Priority: -1
    
    Explanation: do not block ffmpeg-extra but lower priority than debian
    Package: chromium-codecs-ffmpeg-extra
    Pin: origin "archive.ubuntu.com"
    Pin-Priority: 476
    
    Explanation: another h264 package from ubuntu like ffmpeg-extra, also lower priority than debian
    Package: oxideqt-codecs-extra
    Pin: origin "archive.ubuntu.com"
    Pin-Priority: 476
    
    

    With these changes I have no problem playing videos from the cnn site you mentioned, nor from netflix, amazon, yahoo.


  • Vivaldi Translator

    @JSJB
    @marcosmobley already had that library from @Gwen-Dragon script which currently drag Ubuntu package oxideqt-codecs-extra.
    It just video is blank on CNN for no (currently) clear reasons.

    From inspecting DevTools, CNN deliver video in TS chunks.


  • Vivaldi Translator

    @marcosmobley
    Try these one by one:

    • Disable/enable "Hardware Accel" in chrome://settings/?search=accel
    • Enable chrome://flags/#ignore-gpu-blacklist. Restart Vivaldi.

    BTW, visit https://html5test.com/ to see h.264 support does available in Vivaldi.



  • @dLeon thanks, but none of those worked. here's the screenshot of the html5test 0_1497210007878_Screenshot_vivaldi.png and videos seem to work every other place. it's very strange.


  • Vivaldi Translator

    @marcosmobley
    Ugh. This is become more confusing.
    All standard things already ruled out:

    • libffmpeg library, check.
    • Hardware problems, no.
    • No extensions, check.
    • Clean Vivaldi profile, check.
    • Other browsers, work.
    • Network delay, no. Other browsers does work.
    • DE Compositor, no. Other video work in your same Vivaldi.
    • UserAgent, no. CNN video work in others & my Vivaldi.
    • Stealing info from neighbor browser forum about CNN video, just got advice to install point 1 above, lol.

    Currently I'm out of any other ideas. :sweat:


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.