videos of a particular domain not shown anymore with V-stable, V-snapshot still ok



  • I am using V-stable daily for a while now. Videos on msnbc.com worked. Now for some unknown reason I can't view videos on msnbc.com anymore, they do not appear, neither does the turning circle which normaly indicates that a video connection is going to be initiated. Codecs are up to date, no problems with V-snapshot, and again, this used to work with V-stable. It stopped working about two/tree days ago.

    This seems somehow domain related and limited to this domain as videos play with other domains in europe and us. But they don't play with msnbc.com and V-stable, whereas they play with V-snapshot.

    Any suggestions?





  • ./vivaldi-libffmpeg-install-1-1-4.sh

    The latest oxideqt-codecs-extra (1.21.5) is already installed

    I use Gwendragon's script.

    EDIT:
    deleting ~./config/vivaldi "solves" the problem. But obviously this can't be the real permanent solution.

    Which setting could be the culprit?


  • Vivaldi Translator

    @michaa7
    I have no problem playing videos in msnbc.com (cherry pick) with Vivaldi stable.

    But then again, I "steal" & extract Arch package from here (Even that I use Linux/Debian sid amd64).
    https://repo.herecura.eu/herecura/x86_64/ (x64) or
    https://repo.herecura.eu/herecura/i686/ (i386)
    Currently, the version of libffmpeg in that repo identical with current Vivaldi Snapshot Chromium.

    This seems somehow domain related and limited to this domain as videos play with other domains in europe and us

    Sorry, you mean Geo restriction?
    I don't know about that, I don't test that scenario. At least video play from here Asia.

    BTW, I'm wondering, do you use HTTPS Everywhere and block 3rd party cookies? Because I need to disable that extension & enable 3rd party cookies in Vivaldi Snapshot or msnbc.com page broken & video frame just black like in your description.



  • @dLeon said in videos of a particular domain not shown anymore with V-stable, V-snapshot still ok:

    @michaa7
    I have no problem playing videos in msnbc.com (cherry pick) with Vivaldi stable.

    It is working here, too, but only with a new vivaldi home directory. So I'd like to find out which entry in my vivaldi directory is the one that now prevents videos from msnbc.com being displayed.

    May I delet all cookies or cahce or what else may have an direct impact to a domain.

    But then again, I "steal" & extract Arch package from here (Even that I use Linux/Debian sid amd64).

    Yoe did read my posting entirely? This isn't a codec problem as videos with msnbc.com did word with these codecs and still work witrh a new vivaldi home directory.

    Sorry, you mean Geo restriction?

    No I don't and there obviously is no Geo restriction.

    BTW, I'm wondering, do you use HTTPS Everywhere and block 3rd party cookies? Because I need to disable that extension & enable 3rd party cookies in Vivaldi Snapshot or msnbc.com page broken & video frame just black like in your description.

    I don't have installed a single extension.



  • @michaa7 Did you install with my script as root or as user?
    As user the lib is only installed on $HOME/.local/lib/vivaldi/

    I prefer installing as root so all Vivaldi installations will get the updated libffmpeg.


  • Vivaldi Translator

    @michaa7

    But then again, I "steal" & extract Arch package from here (Even that I use Linux/Debian sid amd64).

    Yoe did read my posting entirely? This isn't a codec problem as videos with msnbc.com did word with these codecs and still work witrh a new vivaldi home directory.

    That's just info where I get mine, due Vivaldi Forum & Help introduce helper scripts.


    My entire 1st reply also based on guessing, seeing it's only happen on your Vivaldi Stable with no apparent reasons I could understand. All I could do, to help searching any possibilities.

    Because you already kick possibilities such library, extension, & 3rd-cookies. The current I could think of, "Chromium based different?"

    From your second post

    Which setting could be the culprit?

    What settings did you change then?



  • I now "solved" it by creating a new ~./config/Vivaldi directory ...

    which now forces me to redo all changes I ever made. I HATE it, and I even hate Vivaldi's import functionality which is the most sensless thing I ever saw on Vivaldi (offering "Vivaldi" as default import path is ridicoulos if you create e new Vivaldi directory wherein you need to import to. Then letting the user find out he first has to deactivate the standard setting, otherwise he would never see the option to choose a different path. And finaly, throwing the bookmarks and whatelse without notification somewhere. This does not qualify as thoroughly thought through).

    But guess what, msnbc.com videos work again ... Nobody will ever know which setting caused Vivaldi to refuse to play videos from that domain from one day to another whithout any obvious change.


  • Vivaldi Translator

    @michaa7

    I now "solved" it by creating a new ~./config/Vivaldi

    Good to hear.

    Vivaldi's import functionality

    That import and also export function need to be re-touch for sure, time will tell. I say the current quality is "better than nothing".



  • So, now it happend again. The only way I can play videos from msnbc.com is to delete my vivaldi home directory. With my current home it today does not work anymore although it worked yesterday.

    This realy makes my angry as it is too much work to find out what files I need to copy until I get at least partially back the look and funktionality (passwords, bookmarks) I need.

    This really is frustraiting. And it gets even worse when I open vivaldi with the new created home vivaldi directory and have to watch this animated fidgeting vivaldi forum icon. It seems even developers who aim to be as user oriented as the vivaldi ones are have to have their blind spotts. Please, is there a way (other then deleting) to stopp the vivaldi forum icon animation. It is awesome in the worst possible way.

    And back to the video issue. Which file(s) in the vivaldi home directory supposedly are the ones dealing with videocodes? I really don't like to reconfigure vivaldi every few weeks and hope that with your help I may find the culprit.



  • @michaa7 Stop the vivaldi forum animation? Exchange the sd thumbnail, but yeah, whenever you start fresh you will see it.



  • @luetage said in videos of a particular domain not shown anymore with V-stable, V-snapshot still ok:

    @michaa7 Stop the vivaldi forum animation? Exchange the sd thumbnail, but yeah, whenever you start fresh you will see it.

    Exchange? How, and with what.

    And as it is currently, it is an awesome POS. I really cannot understand how on earth someone responsible could ever allow such distracting, nerving , crying thingy to represent the first point of contact. That's unbelievable. It is a huge contradiction to all fundamental ideas vivaldi stands for.


  • Vivaldi Translator

    @michaa7
    Again, video just play there for me.
    Play after I enable 3rd party cookies for player.theplatform.com. And I even access it far from US.
    I'm out of ideas why msnbc.com video back & forth play/not play on you. I couldn't reproduce it.
    I even feed the address to youtube-dl + mpv/vlc. Video just play.

    I don't know what you want to do with videocodes. But most multimedia handled with /opt/vivaldi(-snapshot)/lib/libffmpeg.so or $HOME/.local/lib/vivaldi/libffmpeg.so if you install it.



  • @dLeon said in videos of a particular domain not shown anymore with V-stable, V-snapshot still ok:

    @michaa7
    Again, video just play there for me.
    Play after I enable 3rd party cookies for player.theplatform.com. And I even access it far from US.
    I'm out of ideas why msnbc.com video back & forth play/not play on you. I couldn't reproduce it.
    I even feed the address to youtube-dl + mpv/vlc. Video just play.

    I don't know what you want to do with videocodes. But most multimedia handled with /opt/vivaldi(-snapshot)/lib/libffmpeg.so or $HOME/.local/lib/vivaldi/libffmpeg.so if you install it.



  • Play after I enable 3rd party cookies

    That's it. Thanks. I changed this yesterday. Works again.



  • @michaa7 said in videos of a particular domain not shown anymore with V-stable, V-snapshot still ok:

    @luetage said in videos of a particular domain not shown anymore with V-stable, V-snapshot still ok:

    @michaa7 Stop the vivaldi forum animation? Exchange the sd thumbnail, but yeah, whenever you start fresh you will see it.

    Exchange? How, and with what.

    And as it is currently, it is an awesome POS. I really cannot understand how on earth someone responsible could ever allow such distracting, nerving , crying thingy to represent the first point of contact. That's unbelievable. It is a huge contradiction to all fundamental ideas vivaldi stands for.

    With the release of Vivaldi 1.10 you can set custom thumbnails for your speeddials. Just hover the icon and click the + in the left corner.
    If you don't have a suitable thumbnail available, look at the thread by @D0J0P
    https://forum.vivaldi.net/topic/17568/i-made-a-huge-thumbnail-pack


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.