Rocker gestures



  • Hi all, I have an issue with mouse rocker gestures.
    I have never been able to use the "back" rocker gesture, while the "forward" one works perfectly.

    When I try to use the "back" gesture, as soon as I click with the right mouse button the menu is shown, even before I release the button.

    This is not how it is supposed to work I think, because if the menu pops-up the rocker gesture will never work.

    Is it only me? I don't see other reports of this problem in the forums.

    Thank you in advance.
    Cris


  • Vivaldi Translator

    @Cris70
    This?
    0_1496220294808_maim_2017-05-31_15-43-36.png

    I got no problem with it.

    Default are:

    • Click Hold Right then Click Left to back history.
    • Click Hold Left then Click Right to forward history.

    For me it's the other way around as I swap mouse button for Left Hand (Windows Mouse Settings Idiom).

    No default Right Click Menu pop-up (or any) show up.


    Linux/Debian sid amd64.
    Vivaldi Stable 1.9.818.50
    Vivaldi Snapshot 1.10.856.16
    Openbox WM.
    Fluxbox WM.
    XFCE4/XFWM.



  • @dLeon said in Rocker gestures:

    I got no problem with it.

    Thank you dLeon.
    I guess it's only me then.
    I think I have to try with a clean profile to see if the problem persists.
    Does anybody know how to start with all extensions temporarily disabled (provided it's at all possible)?

    TIA
    Cris


  • Vivaldi Translator

    @Cris70
    Try, --incognito
    By design, no extensions allowed to load in incognito mode right? Except you choose to enable it.

    If you're thinking about Firefox equivalent Safe Mode. I've got same question.



  • @dLeon said in Rocker gestures:

    If you're thinking about Firefox equivalent Safe Mode. I've got same question.

    Yes, that's exactly what I was thinking about! :O



  • @dLeon said in Rocker gestures:

    @Cris70
    Try, --incognito
    By design, no extensions allowed to load in incognito mode right? Except you choose to enable it.

    Tried with --incognito, no extension was enabled. However, the problem was still there.

    I am starting to think that it may depend on the way the DE handles mouse actions. Which DE are you on? I'm on KDE 5.

    Cris



  • @Cris70 FYI mouse rocker gestures also work fine for me, & i also do use a Plasma5 distro.
    ..............................................................................................
    Tower & Lappy = Maui Linux 17.03 x64 Plasma 5.9.3.
    Vivaldi 1.10.856.16 (Official Build) dev (64-bit)

    ..............................................................................................


  • Vivaldi Translator

    @Cris70
    I'm not DE mainly, most of time Openbox WM.
    But sometime (once a year :grin:), I fire my XFCE4.

    I tailored my system from ground up one by one. No usual random things running in background usually introduced by full distro, metapackage or Desktop Environment.



  • @Steffie said in Rocker gestures:

    @Cris70 FYI mouse rocker gestures also work fine for me, & i also do use a Plasma5 distro.

    I am really puzzled as to what is causing this on my side.
    I am using focus-follow-mouse, but I've tried disabling it and nothing changed.
    I'm one openSUSE Tumbleweed, with plasma 5.9.5. But this has been a problem since the first day I used Vivaldi, months ago.
    Vivaldi is v1.10.856.16, 64bit.


  • Vivaldi Translator

    @Cris70
    Suggestion to test:

    • New plasma profile.
    • New linux user & plasma profile.
    • Maybe test it in other DE or WM.

    Test them with your current Vivaldi profile & clean one.

    All of that if your hardware mouse & its settings wasn't the problem from start.



  • @Cris70 said in Rocker gestures:

    I am using focus-follow-mouse, but I've tried disabling it and nothing changed.

    Ditto:
    0_1496231442872_upload-2f727e09-a9f9-4d5d-a20c-fcc34648510a

    @Cris70 said in Rocker gestures:

    I'm on openSUSE Tumbleweed, with plasma 5.9.5.
    Vivaldi is v1.10.856.16, 64bit.

    Ah. I have that in a VM. Firing it up now [expect it will need some updates; not launched it for a week or so], then i shall try V-SS there. Will report back soon.

    ..............................................................................................
    Tower & Lappy = Maui Linux 17.03 x64 Plasma 5.9.3.
    Vivaldi 1.10.856.16 (Official Build) dev (64-bit)

    ..............................................................................................



  • @Steffie As you can see, NOT the current V-SS [>500 openSUSE Tumbleweed plasma 5.9.5 updates are in progress, & i'm too impatient to wait]:

    Vivaldi 1.10.845.3 (Official Build) dev (64-bit)
    Revision df584d06dcb8232b5f0f8862a1f92af5549a085c
    OS Linux
    JavaScript V8 5.8.283.38
    Flash (Disabled)
    User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.114 Safari/537.36 Vivaldi/1.10.845.3
    Command Line /usr/bin/vivaldi-snapshot --user-data-dir=/home/steffie/.config/vivaldi-snapshot --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --flag-switches-begin --flag-switches-end
    Executable Path /opt/vivaldi-snapshot/vivaldi-snapshot
    Profile Path /home/steffie/.config/vivaldi-snapshot/Default

    ...& also atm this is a bare-bones V-SS installation [configured all its Settings to my "usual preferences", but have not installed any of my std 17 extensions, nor copied across my bookmarks, notes, history etc files from my "real" V-SS in Maui [from whence i type this now]]...

    ...but... mouse rocker-gestures also DO work fine in it.

    So, it is comprehensively not a "Plasma5" issue, nor an "openSUSE Tumbleweed, with plasma 5.9.5" issue. As per @dLeon, the next thing i'd try if you, would be a clean profile. Good luck.



  • Thank you @Steffie for taking the time to try this.
    What is odd is that I have two tumbleweed systems (one is my desktop at home, the other is the laptop I use at work) and both show the same behavior.
    Definitely there is something in the way I use/configure my systems that is triggering the bug.

    Will do the tests @dLeon suggested and then I will report back.

    Thank you!
    Cris



  • @Cris70 Good luck -- am keen to hear what you discover.



  • @Steffie, I'm quite baffled by what I've discovered (or should I say NOT discovered)!
    Yesterday I took the time to create a new user on my laptop and did a few experiments.

    First of all, let me say that Vivaldi, for the new user, worked as expected: mouse rocker gestures were working.
    Then I spent quite a lot of time trying to recreate my original Vivaldi setup to see when (and if) it would break. It never broke.
    Then I returned to my usual user, feeling bad for not having been able to recreate the problem.

    To see once again the exact way in which the problem manifests itself on my original setup, I fired Vivaldi and... the problem was not there anymore!!

    I did various experiments, but it seems the problem is completely GONE.

    I just can't understand how this can be possible. The only thing I can think of is that, in the meantime, there has been an update of vivaldi-snapshot and maybe the new release has fixed whatever problem there was that was causing rocker gestures to not work for me.

    Cris


  • Vivaldi Translator

    there has been an update of vivaldi-snapshot and maybe the new release has fixed whatever problem there was that was causing rocker gestures to not work

    I felt funny, seeing that. I saw changelog about that on recent Opera Developer channel instead.



  • @Cris70 Oh wow, cool that it's good now... just do what i generally do; blame it on sunspots, poltergeists, or malicious pixies.


  • Vivaldi Translator

    @Steffie
    Smurf?



  • @dLeon said in Rocker gestures:

    @Steffie
    Smurf?

    Ah! Yes!!! Those evil little blue creatures!
    Especially the angry one who is grumbling all the time!!!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.