Opening Links from Document Viewer



  • Hi! I just received the error "Failed to execute child process "/usr/bin/vivaldi-stable" (Permission denied)" when I tried to open a link in Document Viewer in Ubuntu 16.04. I tried the link just in the browser itself – it works fine – but I'm wondering if it's having issues using Vivaldi to open pages as my default browser. I'm not sure that's the reason, though; that's just a guess.
    Let me know if you have any explanations and/or fixes.
    Thank you!



  • On my system, /usr/bin/vivaldi-stable is a link to /opt/vivaldi/vivaldi which is the real vivaldi startup script.

    However, /usr/bin/vivaldi is a link to /etc/alternatives/vivaldi which is a link to /usr/bin/vivaldi-stable which (as above) is a link to /opt/vivaldi/vivaldi!

    That's complicated, but it would suggest that if you can start vivaldi from your GUI (however you do it) you should be able to start it via Document Viewer.

    All I can suggest is that you check that the files and links exist and have the correct permissions.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.