Flash plugin is present but doesn't work



  • Plugin is installed, at vivaldi://about I can see:

    Vivaldi	1.10.845.3 (Official Build) (64-bit)
    
    Flash	25.0.0.171 /Library/Internet Plug-Ins/PepperFlashPlayer/PepperFlashPlayer.plugin
    
    Command Line	/Applications/Vivaldi.app/Contents/MacOS/Vivaldi --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --ppapi-flash-path=/Library/Internet Plug-Ins/PepperFlashPlayer/PepperFlashPlayer.plugin --flag-switches-begin --allow-nacl-socket-api=* --disable-accelerated-video-decode --enable-experimental-web-platform-features --enable-fast-unload --enable-quic --enable-zero-copy --top-chrome-md=material-hybrid --enable-features=PreferHtmlOverPlugins --flag-switches-end
    

    Still what I see on http://get.adobe.com/flashplayer/about/ is
    0_1495798736785_Screen Shot 2017-05-26 at 14.38.33.png

    Is that a bug or some kind of misconfiguration?



  • Nah, everything should be fine.
    https://www.codegeek.net/services/resources/flash-player-test-page/
    Test here if you want to make sure.



  • @luetage on that page I get

    Which Flash Player Version Do You Have Installed?
    Javascript is enabled in your web browser.
    You do not have Flash player installed.



  • That's strange, because your "about vivaldi" shows the correct path to the flash player.

    I see in your command line that you have many flags enabled. Maybe reset the flags and try again.



  • So the culprit is Webpages/Plugins/Flash plugin setting.
    If it is set to "Detect and Allow Important Flash Content Only" - there is no way to make a particular flash working by clicking.

    Which I consider to be a bug as user actions should have priority over whatever browser engine considers to be important content.



  • @luetage it's a bit offtop, but how do I submit a bug report? Is this post + comments enough or additional actions are required?



  • https://vivaldi.com/bugreport/

    But this is not a bug, you just have to change this setting. I thought "allow flash" is actually the default, at least I never changed it on my install and this is what I have.



  • @luetage said in Flash plugin is present but doesn't work:

    But this is not a bug, you just have to change this setting

    That setting should not prevent from using flash plugin on click. User intention should have higher priority, especially considering setting is about "non-important", i.e. it's not a "strict" setting.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.