"Vivaldi is unresponsive. Relaunch now?"



  • I just tried clicking a link in Outlook and I got this message "Vivaldi is unresponsive. Relaunch now?" If I click "no" quickly enough then it closes Vivaldi, but I can relaunch without all my extensions being disabled. Otherwise it disables all my extensions. I'm on Windows 10, the latest stable version of Vivaldi, and the following extensions:
    Adblock Plus
    Dashlane
    Evernote Clipper
    Foxit PDF maker
    Ghostery
    Multi Highlighter
    Pocket
    Session Buddy
    WOT

    All of which have worked fine until now.


  • Moderator

    @oscarrob Tell us something about your hardware?



  • @Ayespy Dell Precision laptop, 32 gb ram, 64 bit


  • Moderator

    @oscarrob: Modern processor and video card? A TON of stuff has come up recently with video hardware and the two latest Chromium updates.



  • @Ayespy Yes.
    Processor: Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz, 2901 Mhz, 4 Core(s), 8 Logical Processor(s)
    Video Adapter: NVIDIA Quadro M1200

    What kinds of problems. Would this cause the issue? Any solutions coming? Kind of annoying.



  • @oscarrob Does the same issue appear with Outlook in Private Window (is extensions deativated)?


  • Moderator

    @oscarrob: It's been mostly weird and random things. This person can't install extensions, that person can only play certain kinds of videos, another can't start the browser, this one over here suddenly has jittery video, still another installed fine and now can't update it, scrolling problems that come and go, some users are suddenly getting blank pages. It's all over the map. Yet several have been fixed by either turning on or tuning off hardware acceleration or overriding the hardware blacklist.



  • @Ayespy How do I do those things?

    BTW, I just tried it again from my outlook and if I said yes twice, it re-launched without disabling my extensions, but it didn't connect to the link I was trying. This happens on every link, I've tried multiple links.


  • Moderator

    This strikes me as a problem with Windows/Outlook, which has a problem fully registering non-Microsoft browsers as default, and which doesn't want you to use non-Microsoft browsers. I have a few apps on this machine that, even though Vivaldi is my default, don't even LOOK for a default browser. They only open Edge. Outlook (which I don't use) may be looking for some specific feedback from the browser that Vivaldi is not built to send.

    But you can find blacklist settings at vivaldi:/flags and then ctrl+f search "black"
    Hardware settings same place, search "hardw"
    and more in underlying chromium at chrome://settings/search#a and then use the search box at the top to search "hardware."



  • @Ayespy While I was awaiting your answer, I thought I would try Chrome to make sure it worked in Chrome. So I signed into Chrome and set it up. In advanced settings however I disabled "Continue running background apps while Chrome is closed" and "Use Hardware acceleration when available." I closed chrome and then tried my links again with Vivaldi as my default (I had not changed it). And the links worked. Weird.


  • Moderator

    @oscarrob: Do you have "continue running background apps" turned off for Vivaldi? Vivaldi has that setting as well, and I wonder if turning off the Chrome setting affected Vivaldi. It's a known issue that if ANY Vivaldi processes continue to run after shutdown, it won't start again.



  • @Ayespy I don't see that setting, unless its in flags and then, if its the one I think it has default as the status.



  • why email cant login...invalid product popup



  • @Ayespy By the way. If I close Vivaldi. Then use a link from outlook it works and links from Outlook continue to work. If I have Vivaldi open and have not followed that procedure, links cause the error described above.



  • @oscarrob You can find the "continue running..." setting here: vivaldi://chrome/settings/search#hardw



  • @mbi2 said in "Vivaldi is unresponsive. Relaunch now?":

    why email cant login...invalid product popup

    please read/discuss at https://forum.vivaldi.net/topic/17040/product-license-is-invalid



  • This post is deleted!


  • This post is deleted!

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.