Does MP4 still not work?



  • I see some old posts regarding support for MP4/H.264. In my setup on macOS Sierra with either Vivaldi 1.9 or the new 1.10 snapshot, this seems to not work. I discovered it when I tried to watch a video in Udemy. It can be reproduced by clicking the "Watch Video" button on this page: https://www.brightcove.com/en/player

    Is this still a known issue or have I got something set up incorrectly somehow? All of these work fine in Safari, Chrome, and Opera.

    About:

    Vivaldi 1.10.845.3 (Official Build) (64-bit)
    Revision df584d06dcb8232b5f0f8862a1f92af5549a085c
    OS Mac OS X
    JavaScript V8 5.8.283.38
    Flash (Disabled)
    User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.114 Safari/537.36 Vivaldi/1.10.845.3



  • @bkocik said in Does MP4 still not work?:

    brightcove.com

    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add a link to a testpage where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!



  • Moderator

    @bkocik If you go to vivaldi://gpu does it show that hardware acceleration is unavailable?

    If so, I've already reported the bug: VB-28551



  • @xyzzy I'm not 100% sure what I'm looking for, but I think this is telling me that it's available?

    Graphics Feature Status
    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Hardware accelerated
    Rasterization: Hardware accelerated
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    VPx Video Decode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated



  • @xyzzy Oh - I'm not very smart. Disregard that. I'm on a different machine now, and on this machine those videos work fine. It's my older MBP at home where they don't work, and I can't check now but I suspect that one lacks GPU acceleration. I'll check it when I get home, but it's probably the same bug you've already filed. Thanks...



  • @bkocik We know some old Macs fail with hardware acceleration. :(
    And MP4 needs hardware acceleration for some encode videos.
    Sorry, as i know this unfixable by Vivaldi devs.



  • @Gwen-Dragon Okay, I appreciate the response. Maybe it's just time to buy a new Mac. :)

    Just out of curiosity, do you know how other browsers have been able to make it work? And one other question, given a bug number is there somewhere I can go look at the bug report? (I've been Googling but without success.)

    Thank you!



  • I do not know how they fixed it but i think they programmed own codecs.
    It is very time consuming and teh right hardware is needed to check why a old computer wont run a MP4 video.

    Which old Mac OSX do you have? I may search for you a related bug with old Macs in Vivaldi bugtracker.

    I found a confirmed bug "VB-22330 MPEG Videos not playing on YouTube ā€¦" with some videos not playing on Mac OSX 10.12.5.

    Perhaps you can try to disable the Blacklist for GPU + hardware decode of video.
    Try:
    //EDITH:
    Set a flag:
    vivaldi://flags/#ignore-gpu-blacklist
    vivaldi://flags/#disable-accelerated-video-decode

    PS: Sorry i am a Linux and Windows user, i cant tell much how to edit/create a desktop shortcut for such paramater setting.



  • @Gwen-Dragon I don't have it with me to verify, but I'm pretty sure it's a mid-2012 MacBook Pro.

    I'll try launching Vivaldi with that flag when I get home this evening and see if it makes a difference; I'll let you know either way. Thank you so much for your help, I really appreciate it!



  • It depends on your graphics card. Do you have an igpu?



  • @Gwen-Dragon said in Does MP4 still not work?:

    Set a flag:
    vivaldi://flags/#ignore-gpu-blacklist
    vivaldi://flags/#disable-accelerated-video-decode

    @bkocik

    thank you so much for your help, I really appreciate it!

    I try what i can.


  • Moderator

    @bkocik I'm actually in the same boat as you. The Chromium developers blacklisted the GPU on my MacBook, most likely to work around some performance/stability issues with their GPU acceleration code on this hardware. I can still play that video in Chrome because it was built with codecs that work with software-based rendering. Not so with Vivaldi, most likely due to licensing issues.

    You can override the blacklist by enabling the #ignore-gpu-blacklist flag as a test:
    vivaldi://flags/#ignore-gpu-blacklist

    However, this is not really an effective workaround because the GPU was after all blacklisted for a good reason. On my system, I've personally run into performance issues where scrolling can be painfully slow/glitchy on some sites. Your level of breakage may vary.



  • @xyzzy Just to close the loop: You're right, I'm home now, and this is exactly my issue. This machine doesn't have GPU hardware acceleration available. Setting that flag allows Vivaldi to play the video at Brightcove and also the Udemy videos.

    I may be opening myself to stability issues by setting that, but at least I know what the problem is. Thanks again for everyone's help in diagnosing.



  • @bkocik Your issue was solved after you disabled Hardware Acceleration on internal settings page?
    Fine. :)



  • @Gwen-Dragon I would doubt that. Since he has a 2012 macbook pro he likely has an igpu, possibly a hd3000. So he set the #ignore gpu blacklist flag.



  • @luetage Correct, this was what I meant when I said "setting that flag," the #ignore-gpu-blacklist flag. That makes the videos playable on my personal MBP where the problem was. Sorry if that was unclear!


  • Moderator

    I see that this thread has been tagged as Resolved but I don't think that this is the case at all.

    The Chrome/Chromium developers are partly responsible because they're blacklisting GPUs/drivers, old and new, that are causing glitches with their acceleration code. In the past, when we found a rendering glitch, we (as users) disabled hardware acceleration as a workaround. Google is now doing this for us. I don't know if they see this as a temporary measure (until they get their code fixed) or a permanent solution but at least Chrome does not break when it falls back to software-based rendering.

    Vivaldi needs to accept the reality that this is happening and do something about it. At the moment, there are a lot of Mac users out there whose browsers are now in a perpetually broken state -- With the GPU blacklisted, many common media formats cannot be decoded; By overriding the blacklist, the media plays but hardware-accelerated rendering is broken.

    Sorry, as i know this unfixable by Vivaldi devs.

    @gaelle It's not sustainable for Vivaldi to drop support for the affected Mac users. Right now, their only recourse is to switch to another browser. Thanks...



  • @Gwen-Dragon We've spoken about this issue in other threads. This might apply to some old Macs, but brand new Macs have this issue including mine. If you are running the Mac Pro with the D500 video card (and I assume the D700), MP4 is broken on Vivaldi, but not Chrome. I understand that the Devs might not want to fix it because it's a small portion of the population, but then Vivaldi should say they don't have interest in supporting some of Mac line and Windows/Linux is the target market rather than saying "...some old Macs". I've been waiting for an update since 1.4, so it is disappointing to hear Vivaldi won't be able to fix this as I have to have Safari up at the same time as Vivaldi quite often. Otherwise, it's a very nice browser and works nice on my 2015 Mac Book pro...



  • @chainlightning I couldn't agree more. I have a "new" late 2013 mac pro with a D300 card. I have to keep Safari open to be able to use Vivaldi. I copy URLs and paste into Safari. I've unsuccessfully tried suggested solutions. Surely Vivaldi can address and fix this problem. Please, please.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.