Chrome/Chromium flash filter not supported?



  • I needed Flash in order to play some video on animenewsnetwork.com. On its own, Vivaldi doesn't seem to play Flash video (I gather only Chrome proper has it built in), so I installed the PPAPI version of the Flash video player (yes, definitely PPAPI). Flash video then worked on that site. So far so good.

    However, I don't want Flash to work anywhere else. Too many security flaws. So, I disabled Flash in vivaldi://chrome/settings/content (also possible at vivaldi://settings/webpages/) and then, before adding a whitelist entry for ANN, went to test to make sure it was disabled. It wasn't. I did a hard reload on the page. I tried different pages to be doubly-sure. Flash just kept on working. I added an explicit blacklist entry for the site. Still kept working.

    Is this feature of Chrome not supported without the built-in player it has? It seems to do nothing for the pepper version.

    If it's not supported... could it be? :) I hate all the security issues with Flash and the lack of this filter is a decided drawback to Vivaldi vs. regular Chrome.

    In case it's useful, here's the About infodump:

    Vivaldi 1.9.818.49 (Stable channel) (32-bit)
    Revision 67716ff62f654eb92d8fc3c533d9b8fdc664c04e
    OS Windows
    JavaScript V8 5.8.283.37
    Flash 25.0.0.171 C:\Windows\SysWOW64\Macromed\Flash\pepflashplayer32_25_0_0_171.dll
    User Agent Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.97 Safari/537.36 Vivaldi/1.9.818.49
    Command Line "C:\Program Files (x86)\Vivaldi\Application\vivaldi.exe" --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --ppapi-flash-path="C:\Windows\SysWOW64\Macromed\Flash\pepflashplayer32_25_0_0_171.dll" --flag-switches-begin --enable-display-list-2d-canvas --num-raster-threads=4 --enable-overlay-scrollbar --disable-smooth-scrolling --enable-features=AutomaticTabDiscarding --disable-features=NoStatePrefetch --flag-switches-end
    Executable Path C:\Program Files (x86)\Vivaldi\Application\vivaldi.exe
    Profile Path C:\Users\xxxxxx\AppData\Local\Vivaldi\User Data\Default
    Compiler MSVC 2015


  • Vivaldi Translator

    @Felice_Enellen

    --always-authorize-plugins

    From my research, it seem that command line flag was the cause for "Always allow plugins".



  • I'm not adding that flag. My shortcut for Vivaldi has no flags added at all, and it's there whether developer mode is on or off. I don't see anything that corresponds to it in vivaldi://flags either. Judging by other people's posted command lines, it's pretty much standard.

    Do you know how to remove it?


  • Vivaldi Translator

    @Felice_Enellen
    Ah okay, seem that one command line kind of common on some system. No idea why.
    Still; I see there was a bunch uncommon command line flags there, even for Chrome.

    How did you start Vivaldi?

    View things to test;
    Easy:

    1. Check your Vivaldi shortcut for those extra.
    2. Disable all extensions.

    Advanced:

    1. Rename/Move "Local State" file in your Vivaldi profile to something else. Make sure Vivaldi was not running before hand. "Local State" file used by Chromium to place config if we play with chrome://flags (vivaldi://flags). This just for test; you did note that nothing changed in Chromium flags page.
    2. If still persist; try clean Vivaldi profile just to see if those extra still there. Of course, also test if the flash blocking also work.

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.