[bug] CTRL+B opens bookmark manager, even inside of text box



  • hi. first of all, congrats on the great work.

    when i'm writing messages I need to use CTRL+B to apply bold style to some text, but it always brings the bookmark manager up too. formatting is applied, but I have to close that window all the time.

    shouldn't keyboard shortcuts be sent only to active text box (like the one we write these posts)?

    thanksm


  • Moderator

    @Maurik: Known bug. If you don't want to use Ctrl+B to open bookmarks, then simply remove the shortcut from menu/settings/keyboard.



  • This bug affects more than just Ctrl-b. I have the CopyURL+ extension, and when I type in a text box its single-letter shortcut keys to copy the page URL often fire off continually, which I can see in my clipboard manager's pop-up. Not all text boxes, but many. The text boxes are supposed to take precedence over the page once they are in focus.



  • @Maurik @paul1149
    Until this is fixed you can also assign a shortcut to disable / enable shortcuts to workaround this problem.
    You can assign this at:
    Settings --> Keyboard --> in the section "Page" --> "Disable Keyboard Shortcuts"



  • @Ayespy thanks for confirmation. within minutes of posting the message here, I was able to find the settings page and remove Ctrl+B (I am using Vivaldi for 3 days now). anyway having textboxes capture input before keyboard shortcuts would be nice.

    also I re-assigned the Quick-Commands to Ctrl+F2, releasing F2 to be used by online spreadsheets sites. having the option to change this kind of setting is amazing! please share my congrats for the great job to Vivaldi team!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.