Vivaldi & Youtube: playlist problems

  • Hello,

    as I get no answers in the german forum, I'll try it here.

    When I try to add a youtube-video to my playlist by clicking on "add", this does not work (I think it is "add" in the english version).
    There only appears a little popup-window with "add" and (behind the rotating point) it says "Playlist is loading" (again: I do not know the exact english wording). But nothing happens, even if I wait several minutes.
    There are no such problems with Microsoft's Edge browser, where the playlists appear immediatly
    So what might be Vivaldi's problem here?

    Thank you in advance for every answer!

  • Moderator

    I've been able to add random videos to playlists on YouTube in both the new Material Design layout and in the classic layout. It should work for you too. I'm using Vivaldi 1.9.818.50 (x64) on Windows. Here's what you could try:

    1. Force reload the page and all of its contents including scripts, styles and images (by default: press [CTRL] + [SHIFT] + [R] or [CTRL] + [F5]);
    2. Open the page in Private Window (by default: press [CTRL] + [SHIFT] + [N] to launch a new Private Window or select Menu > File > New Private Window). If the issue is gone in Private Window, then go to step 4.
    3. Disable all extensions (if this resolves your issue, then try enabling them one by one to check which one is causing the trouble);
    4. Clear browsing data and restart the browser if necessary;
    5. Refresh your profile.

  • No. 1 => No result
    No. 2 => Playlists appear
    No. 4 => no result in the non-privat window
    No. 3 => BINGO: This extension causes the problem:

    (By the way: I'm surprised that extensions do not start in the private window.)

    Pafflick, thank you very much for your help!

  • If you need to block ads on youtube, use uBlock Origin, it works very well with Vivaldi.

  • @Albinoni said in Vivaldi & Youtube: playlist problems:

    (By the way: I'm surprised that extensions do not start in the private window.)

    They don't by default - however, you can enable "allow in incognito" per extension under Tools/Extensions.


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.