Umpteenth plea of desperation for Vivaldi to kill the Google spyware in the browser



  • Even with everything disabled in settings, the browser is STILL--after all these versions--phoning home to Google on launch and periodically while using the browser. This is unacceptable.



  • it shouldn't; what ip address/port? maybe is correlated to a feature - probably chromecast need to phone google to work; if you don't need maybe can be disabled to see if something change. Then, you can try to prevent comunication from vivaldi/to the address in your firewall - hoping won't break any feature in it.



  • Vivaldi is like E.T. Wants to phone home :D


  • Moderator

    @dib_ Doesn't happen here. Do you have Google extensions/services that you use that Vivaldi might be trying to support?



  • @dib_ Or do you have google search suggestions activated? Google anti scam and fishing protection?



  • Vivaldi 1.10.845.3 (Official Build) (32-bit)

    Mostly 172.217.4.109:443, which shows a certificate for accounts.google.com, *.partner.android.com so it's definitely bullshit connectivity.

    All plugins are disabled. All settings are disabled that involve Google. That's the entire point: even if you disable everything, the browser continues connecting to Google.

    I should mention Firefox does the same thing. Even if you disable stuff like data tracking, they do it anyway.

    The difference is Firefox has everything in the about:config so you can null https strings, and that will finally cut the user tracking. Vivaldi needs to put all its switches and strings into a config so we can override them.



  • This post is deleted!

  • Moderator

    @dib_ I can't get my copies of Vivaldi to do that unless I log in to GMail or another relevant Google service - and then it only does it when sending or fetching information that I told it to.



  • If you did the change in firefox (post the strings used there) and still works ok (port 443 is used for certificates), you can make a rule in your firewall to prevent such connection in vivaldi.



  • I'm seeing broadcast connections by Vivaldi to 239.255.255.250 on port 1900 despite having the WebRTC setting under Privacy disabled.

    I'm also seeing frequent connections to 216.58.216.238 (Google) as long as I have the vivaldi://settings/content page open.

    Vivaldi also attempts to connect to 216.58.216.234 when I open the extensions page. I manually nulled the update_url string in each extension's manifest.json file in order to prevent auto updating.



  • Just upgraded 1.10.862.6

    Now I'm seeing frequent broadcasts to 224.0.0251:5353. So where's the option to disable this? I don't see anything added anywhere under Settings.

    This is some serious bullshit, Vivaldi devs. Somebody needs to take you to task on user privacy. This browser should not make a single connection without permission from the user or as required to view actual sites, and everything should have a setting to disable it.


  • Moderator

    @dib_ Vivaldi is not doing that. iTunes or Bonjour may be.



  • If contact to Google anything un-wanted.

    This what came up in my mind currently.
    I agree with @Hadden89 suggestion above, add exception to Google anything to firewall either software and or router.
    Beside that;

    • Block with hosts file. But will be a problem if you use proxy or vpn, as they could use remote DNS & bypass local hosts file read.
    • Block on DNS level. If not mistaken, OpenDNS has this ability. But, that company collect info for them self. Don't know about same other services.

    Plus extra;
    Not necessary if you block in hosts file or even firewall.

    • Don't use any extensions, especially famous one. It's rare to see even the simple extension not have Google code, say, to count how many user they got for example. Don't even visit Chrome extension page. @Ayespy for example, doesn't use extensions, so maybe that's why he don't catch it.
    • Don't use search search suggestions. There's a change your preferred search engine actually contact Google.
    • Don't use page that link to any Google services. Example got maps (Google map). Luckily, Vivaldi use Mozilla service. Unluckily, that's have problem (talked in other thread)
    • Double check your 3rd party programs. Make sure they're not "doing" it. It's include your softwares, OS, or just blatant malwares.
    • Check your ISP not relay (hijack) request to Google. Mine did.

    I'm not joking. Those are common steps I always see, at least what I have in my mind currently. Doing all of that is faster, more logical, & definitely under your control. Note firewall block preferred, as it's lowest level you could get.

    Waiting for application developers could take times. That if that could happen at all for what ever reasons.



  • @dLeon I SHOULD NOT NEED TO block every Google subnet on a firewall in order to run a goddamn browser. There's no reason I shouldn't still be able to go to google.com and use a search engine without my browser taddling on me directly to their servers the other 99.999% of the time it is running. That is bullshit. There are also how-many-other users who don't micromanage their own firewall, and they shouldn't need to run a browser that is taddling to Google.

    And for the umpteenth time, I have every single option disabled concerning search suggestions, extensions etc. If this were as simple as changing some setting I would have done it and wouldn't be wasting my time on this forum.

    So as much as I'd like to say I appreciate the response, you're not helping at all.



  • @Ayespy You're wrong yet again. I just upgraded it on a second system and am immediately seeing the same thing. Outbound UDP connection from vivaldi.exe to 224.0.0.251 port 5353

    I also immediately confirmed the same behavior I just reported with connectivity to 216.58.217.228.


  • Moderator


  • Moderator

    @dib_ My Vivaldi does not do this. Why does yours?



  • @dib_ You're rather rude, aren't you?



  • @Steffie Getting tiresome banging my head against this same wall. Vivaldi talks a lot about privacy but I have yet to see it implemented.



  • @dib_
    Well, my 1st post just options & suggestion. I admit, most of those points are too high level for novice computer user.

    Anyway, judging from the IPs you gave.
    What left (in current Chromium Vivaldi at least), is to at least cut or revamp;

    • ChromeCast/Multicast/Media Router. (224.0.0251:5353).
    • Plug&Play. (239.255.255.250)

    Those IPs not necessary go in/out from your network to outside world. Windows block port 1900 by default. So does, most router I ever use. I block it in/out.

    216.58.216.238 (Chromium settings window).
    216.58.216.234 (Chromium extension page).

    At least I could confirm this two. And agree with you, need at least control able.

    I also see no any multicast IP wondering my network log.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.