Anyone else had an occasional runaway text entry problem in Dev Tools for the last few snapshots?



  • I think this started happening around the time Dockable DevTools was introduced.

    It's hard to know what triggers it, because it only happens occasionally.

    Occasionally when I'll do something like click "edit attribute" in the inspector or start typing in the console, I'll type in a letter like "e" and the letter will start repeating "eeeeeeeeeeeeee" as if I'm holding down the key. If I type further letters, those get repeated, too, so it becomes "eeeeeeeeeeeeeeeeeeeeeexexexexexaexaexaexaexamexamexamexamexamexampexampexampexamplexamplexamplexampleexampleexampleexample..."

    If I was, say editing an element attribute in the inspector, and click on something else like the console or the CSS statement filter, the text starts appearing there instead. I need to close the DevTools instance entirely when this happens.


  • Moderator

    I don't use the DevTools extensively but Vivaldi has a similar (same?) bug elsewhere.

    For example: In Vivaldi Preferences, edit any theme, click on the hex value of any colour, backspace until only the # remains, and then try to enter a new hex value.

    I've reported my issue as a bug - VB-28621. Hopefully it will address yours too.



  • @xyzzy Oh yeah, that one is neat, you practically can't change a theme by hand, you always have to copy paste the values in....

    Can't reproduce the problem with devtools though, or it still hasn't happened to me.


  • Moderator

    @luetage ... or enter them via the macOS "color picker" widget.


  • Moderator

    @Isildur If this issue reproduces consistently, I'd report it as a bug. https://vivaldi.com/bugreport/

    Dockable DevTools are a hot new feature so I'm sure the Vivaldi developers will be quick to investigate it. Also, please include a link to this thread in your report as well in case someone else follows up with additional helpful information.



  • @xyzzy

    The fact that I was having trouble getting it to reproduce consistently is why I've hesitated to report this one via the bug report form yet. I can't yet make it happen on command with specific steps. I'll just be doing things in DevTools like normal, click somewhere to start entering text, and unexpectedly "tttttttttttttttttttttetetetetetextextextextexttexttext..."

    I was hoping someone had discovered specific precipitating conditions I had overlooked and already reported it.


  • Moderator

    @Isildur Fair enough. Your subject line for this topic is great. Hopefully other DevTools users will see it and chime in if they run into similar issues.



  • Here's an example of it happening.

    I was typing in some search text like, l","offset, then I entered an "e" before the quotation mark. I notice it doesn't necessarily add the repeating letters in the order entered. I followed "e" with "a", then "b", then "c", and, seeing it was writing "...beacbeacbeacbeac...", I tried a "h", to see if I could make it "...beachbeachbeach..." but that resulted in "...bheacbheacbheacbheac..."

    Imgur


  • Moderator

    Not reproducible on Windows 10 x64 with 1.10.845.3 (64-Bit)
    Snapshot.
    Looks like a Mac-only issue.



  • I have tried to reproduce this several times, but couldn't. Would be interesting if it has anything to do with the key repeat settings. I tried to get the bug with both key repeat on and off though, and neither triggered anything like this.


  • Moderator

    @luetage I tried to reproduce it as well (on OS X 10.11.6) but couldn't either. In the initial post, @Isildur said that this only happens occasionally but at least the follow-up example shows us how/where this glitch occurs. I don't use the Developer Tools very often but when I do I'll try to be mindful of what I'm doing in case this happens to me.

    @Isildur Does this by chance only occur when you're debugging... and a glitch in your code is somehow (directly or indirectly) involved in triggering this phenomenon?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.