Audio applet produces no sound



  • I am getting no sound from a web page's built-in audio applet.

    I go to https://www.blueletterbible.org/kjv/rom/12/1/t_conc_1058002. There I click on the speaker icons to play audio of the pronunciation of various Greek words. The speaker pulsates, the volume control in ubuntu 16.04 registers Vivaldi playing audio (Vivaldi's volume is set to 100% there), but nothing comes from my speakers.

    The page works fine in Slimjet and Epiphany and Firefox. I've already turned off my adblocker for the site.

    Thanks.


  • Moderator

    @paul1149 said in Audio applet produces no sound:

    I am getting no sound from a web page's built-in audio applet.

    I go to https://www.blueletterbible.org/kjv/rom/12/1/t_conc_1058002. There I click on the speaker icons to play audio of the pronunciation of various Greek words. The speaker pulsates, the volume control in ubuntu 16.04 registers Vivaldi playing audio (Vivaldi's volume is set to 100% there), but nothing comes from my speakers.

    The page works fine in Slimjet and Epiphany and Firefox. I've already turned off my adblocker for the site.

    Thanks.

    It plays fine on Debian 8.8 - make sure you have all the necessary codecs installed. Check here
    What Vivaldi version are you running?



  • Hi @lamarca . Thanks for your reply.

    I'm on 1.9.818.44 (Stable channel) (64-bit). This has been going on for several versions, for months. I'm on Linux Lite 3.4, a ubuntu derivative, the latest version.

    I ran the command at that page and got back that all packages were already installed and up to date. I then tried to run the script posted there and got permission denied, though the author said he had written it not to need sudo.


  • Moderator

    You mean the " latest-proprietary-media.sh"? If so, as a Ubuntu user, you don't need to exec it.
    Did you install the oxideqt-codecs-extra?



  • Yes, it was the codecs-extra that were already installed and up to date.

    I know it shouldn't be necessary to run that script in ubuntu, but I tried it anyway.



  • Hi @paul1149 here it works fine on Mint 18.1 (32bit). What kind of speaker did you use? Are external or LCD integrated? Did you try to listen plugging earphones directly to the pc? Look also at the settings, what output device is set? (usually with right-click on the audio icon on system try, then output device).



  • Thanks for testing, @Marko-Indaco .

    Would that be a factor if virtually everything else works in Vivaldi?

    I have external speakers, which are working and show up in the volume control. When I click the speaker, an entry for Vivaldi appears under the "Playback" tab, then disappears when the track is over.



  • @paul1149 Hmmm it's weird. Seems like an hardware issue, but maybe some codec is missing... Did you try to install Audacity? It could be useful because it install lots of useful codecs during the procedure.



  • Yes, audacity in on the machine.



  • Found the problem. I have an extension, Disable HTML5 Autoplay. Once I created an exception for blueletterbible.org, the audio works fine.

    Thanks.


  • Moderator

    You should always tell us if you have extensions, then we would have given you this advice: Disable in Tools → Extensions all extensions and re-enable step by step to find the bad one.
    And you can test the browser without any extension in a Private Window (Ctrl+Shift+N).

    @paul1149 But you found a solution by yourself. Congrats :)



  • Thanks, @Gwen-Dragon. Disabling the extensions manually I find tedious, as there are quite a few, and some I want to keep disabled. The Ctrl-Shift-n shortcut is excellent however.


  • Moderator

    @paul1149 said in Audio applet produces no sound:

    Disabling the extensions manually I find tedious

    But this step-by-step is sometimes the only ways to find out. Trust me, i know such strange things since oder Mozilla, Chrome and old Opera with extensions.



  • True, I've done it myself many times. But as a first step I prefer a diagnostic that doesn't take a lot of time to undo. The C-S-n shortcut does that. Then, if warranted, I would parse the extensions looking for the culprit.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.