How to stop Vivaldi from auto highlighting the New Tab url address?



  • Hello!
    A little introduction. From time to time I get sick of Chrome's bugs and I try to switch to something different. But there always something comepletely wrong and eventually I come back to Chrome. I tried Vivaldi multiple times through the last year and there always one thing that stops me from using it - Speed Dial.
    I use Speed Dial 2 and I love it. Today I managed to setup Speed DIal 2 in Vivaldi somewhat close to properly. But there one thing that piss me off very much. It's URL address bar. First of all, every time I open new tab it shows the address "chrome-extension://jpfpebmajhhopeonhlcgidhclcccjcik//newtab.html" (in order for Speed Dial 2 to work I edited it manually to open this address. Other way it wouldn't work Inetad I would be seeing a default speed dial). But I can live with that (at least I think so). And here comes the "second of all". When I open new tab, this URL highlights itself. This is really getting on my nerves. Is there a way to remove that?
    P.S. Sorry for my English. It's my second language.



  • In snapshot 1.10 you can go back to using vivaldi://newtab as newtab and startpage, it has been fixed, tested with Speed dial 2 and FVD.



  • @iAN-CooG I'm sorry, but what Snapshot 1.10 is? Is it an extension? I found only the one that makes screecaps.



  • I'm talking about Vivaldi snapshots, the "beta" versions. The day after 1.9 stable was announced, the 1.10 snapshot cycle has started and already had this fix.
    https://vivaldi.com/blog/snapshots/sorting-of-downloads-vivaldi-browser-snapshot-1-10-834-9/



  • @iAN-CooG Sorry. I didn't know that beta versions called "Snapshots" :)
    It works, but not fully. For some reason startup page is not working properly. But new tab, as you can see in video, works perfectely. Here are my settings for startup page. I tried both as Home page and as Specific page.



  • I don't see clearly the video, but appears to me that you have used
    vivaldi:\newtab
    instead of
    vivaldi://newtab
    it makes difference



  • @iAN-CooG Sorry for small image. Here is good size. It's the same address as in New Tab settings. And it works there, but not for the Startup page. Strange.



  • I meant the video not the pic of your settings, anyway I just retried now Speed Dial 2, I see now that I have "startup with last session" not specific page or home page, that causes indeed to make the google page to appear. Press Enter on the address shows the SD2 newtab correctly.
    Please use vivaldi.com/bugreport to have this checked.



  • @iAN-CooG Thank you a lot for your help!
    I submitted a ticket. Hopefully, they will fix it soon. At least, with your help, I don't have to deal with Address bar every time I open a new tab :)



  • I've just retried with today's snapshot. SD2 works now even on startup with specific page chrome://newtab, and set new tab page as controlled by extension. Don't use vivaldi://newtab as that is still showing the google logo
    Reported as
    Summary: vivaldi://newtab in startup still shows google page
    Key: VB-28370



  • @iAN-CooG Thank you again! It works exactly how I expected it to now.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.