"Remove tab spacing in Maximized Windows" intermittant

  • Anybody else have this issue?
    The tab spacing comes back randomly, after maximizing the minimized Vivaldi window.
    I can usually fix it by just minimizing the Vivaldi window again, then when I maximize it the tab spacing is removed.
    Occasionally however (like just now) I have to go back into the settings, untick the setting, and tick it again.

    Running Arch - Manjaro.

  • Yes. I get this all the time.

    Usually when I first start the browser, or open a new window, the tab spacing at the top is present. As you said, minimizing then maximizing seems to fix the issue. Occasionally I have to min/max a few times.

    I'm on Mint 18.1.

  • Cool, it's not just me.
    Is it in the pipeline to be fixed? Do I need to submit a bug report or something?

  • Hi folks, i made some try, and I can say that the tab spacing is noted much more if you have the V Menu instead of horizontal menu, that is mine default setting. (The option Remove Tab Spacing in Maximized Windows is ticked)

    • with maximized window
      0_1494086562658_Vivaldi Forum - Tab Spacing (V button menu - maximized window).png
    • with reduced window
      0_1494086592793_Vivaldi Forum - Tab Spacing (V button menu - reduced window).png
      Instead, using the horizontal menu the difference in space is almost imperceptible (no need to post other screnshots).
      In my case, for exmaple, many times when i move the mouse on the right side (is where I place my panel) and clicking on it, nothing happens. This makes me realize that the window is not really maximized (although it looks like it). So i have to move it off-screen to manual reduce and then, after this, the maximize/reduce button make is job. The strange thing is that sometimes, after a pc reboot, it seems to remember the old settings maximize/reduce as I was setted before. But many times not. I found the same behaviour also with Firefox (but Chromium seems not affected). Could it be something about DE related?
      I'm on Mint 18.1 (32bit - Cinnamon)

  • I'm on Cinnamon as well.

    I do have some other issues with Vivaldi's windows. I'm not sure if it's related, but I have a dual monitor setup with the primary monitor on the right side. Most of the time Vivaldi opens on my primary monitor, but every once in a while the new window opens on the secondary monitor. I've never been able to figure out why. I usually make it a point to move the window over to my primary monitor before closing it, but it still happens. So I'm not sure what's causing Vivaldi to occasionally open on the secondary monitor.

    Another window oddity with Vivaldi is that the settings pop up always opens on my secondary monitor on the left side.

    I know that Mint 18.1 has issues with dual monitor setups. For example, my desktop icons don't show up.

    So I'm unsure if it's a Vivaldi issue or a DE related issue.

  • Not this issue specifically, but similar: sometimes when I unmaximize Vivaldi it retains the spacing it had in its maximized state (which is to say it has no spacing at all) and the window controls become unusable until another window gets focus or until I minimize and restore Vivaldi. Here is a screenshot:

    But I do not have the issue of the tab spacing returning randomly while Vivaldi is still maximized. I'm on Gnome, and, like OP, on Manjaro.


  • With the latest snapshot (1.10.862.6), I haven't noticed this issue. I didn't notice anything in the changelog, but I might have missed it.

    Still occasionally get a new window open on the wrong monitor, but the tab spacing issue seems to be gone.


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.