Mixed Active Content



  • Hi all,

    I am looking into a way to toggle active mixed content, something like this Firefox extension:
    https://addons.mozilla.org/en-us/firefox/addon/toggle-mixed-active-content/

    Or perhaps there is a way to do that in vivaldi://flags?

    Thanks!



  • By default, chromium/vivaldi block mixed content but show an icon on url bar to allow them on the right.
    I don't think there is a persistent option to always allow them but I don't think is a good thing to do however due potential security issues you could have.



  • Hi, thank you for your reply. I am aware of the concept of Mixed Content, unfortunately I have to use certain Artwork Management System that is designed the way I have to allow run more 'stuff' on it.

    I can't see anything on the right side in the URL Bar except:0_1493969892129_Screen Shot 2017-05-05 at 08.37.40.png

    And on the left side (can't find anything relevant there):
    0_1493969919058_Screen Shot 2017-05-05 at 08.37.51.png



  • @pete909 The icon for allowing mixed content (near the bookmark icon), only shows when there is mixed content in the active page



  • @Hadden89 said in Mixed Active Content:

    @pete909 The icon for allowing mixed content (near the bookmark icon), only shows when there is mixed content in the active page

    @Hadden89 thank you, but I can't unfortunately see anything there (as per my previous post)

    Here's the comparison in what see in: Firefox (with toggle-mixed-active-content 2.0 Add On) and Vivaldi:
    0_1493979204389_Screen Shot 2017-05-05 at 11.12.49.png



  • @Hadden89

    I'm viewing this thread because, based on the developer tools console, I think the mixed content issue is why fivethirtyeight's podcast is currently broken for me. For example: https://fivethirtyeight.com/features/emergency-politics-podcast-whats-next-for-health-care/

    Anyway, assuming I'm correct, I also don't see an extra icon.



  • @stokecn yes, podcast is broken also here (tried with ublock off) and don't see any icon. Did you have the mixed content icon before, there?
    Maybe at this point could be a bug for both pages.

    For example, your page in vivaldi says "safe connection" (probably block without saying anything) while firefox says "page not secure" but correctly load the podcast.

    Error given by chromium dev tool loading the podcast:
    s2.wp.com/:280 GET https://cdn16.castfire.com/audio/303/3722/27836/3350862/fivethirtyeightpoli…eatures%2Femergency-politics-podcast-whats-next-for-health-care%2F&s=5L8r1 net::ERR_INSECURE_RESPONSE

    Ok, there is a rough workaround, but actually will LOWER your navigation SECURITY.
    So, try and use ONLY for the site you can't access normally.
    With this, the podcast will play.

    1 Do a new vivaldi shortcut (DON'T use main one)
    2 Name it "vivaldi insecure setting"
    3 Open shortcut properties
    4 In destination checkbox, after vivaldi.exe add this --args --ignore-certificate-errors
    5 Don't EVER use this vivaldi session for other sites, EXPECIALLY important ones.

    Or.... avoid the insecure site. (Ok, is not always possible like for the user above).



  • @Hadden89 is it possible to make a shortcut with "Insecure Settings" for Vivaldi on OS X?



  • @pete909 said in Mixed Active Content:

    @Hadden89 is it possible to make a shortcut with "Insecure Settings" for Vivaldi on OS X?

    Probably, but I don't know how to do them on mac :)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.