Missing spell check settings, missing languages



  • [Reposting from the Linux subforum since I did not receive any replies there and I don't know whether any of these issues are platform specific. Feel free to delete if this is not appropriate.]

    Spell checking seems to be broken in Vivaldi. I'm on Kubuntu 17.04, Vivaldi 1.9.818.22, interface language Nynorsk. What is weird is that this is a new installation and I remember this working fine before. I've seen older bug reports regarding spell checking both for Vivaldi and Chrome, so I would like to know what the expected behaviour is at present.

    • When I right click on a 'misspelled' word, I get no option to switch or add languages.
    • The language menu isn't accessible through the settings. Instead, I have to go to vivaldi://settings/search#språk . (Note that entering 'språk' in the search bar of the settings doesn't give the same result.)
    • In the language menu, it says spell checking isn't available for Nynorsk
    • The dropdown menu only has a limited number of languages. Bokmål and Dutch are missing.

    0_1493132491851_upload-281c2175-2c3c-4628-9be8-0f8594fa4ad8 0_1493132623657_upload-4720b3fd-d4df-4329-827a-c0ef25530e76 0_1493132714735_upload-472cee1e-e564-487a-9678-dee5fdb05365


  • Moderator

    The dictionaries are not provided by Vivaldi, nor Chrome. They are Hunspell OpenSource dictionaries.

    There seems to a single dictionary for Nynorsk and Bokmál.



  • @Pesala Then why isn't it showing up?


  • Moderator

    @oulenz I don't know which dialogue your screen shot is showing, but I had no problem adding a dictionary for Norwegian Bákmal.

    0_1493711787098_Add Language.png

    0_1493711713537_Nynorsk.png



  • @Pesala Like I wrote, I'm showing the 'Add language' dialog in the language menu, accessed by visiting "vivaldi://settings/search#language". I'm assuming so are you.


  • Moderator

    @oulenz I have no idea why you expect to add spell-check languages by visiting the search engines settings.

    1. Right-click in a text edit field such as this message reply box
    2. From the spell-check submenu of the context menu, select "Language Settings."
    3. Under *Languages click the down arrow to expand the list.
    4. Scroll down and click on the blue link Add Languages
    5. Select the languages that you wish to add, and click on Add Languages. After downloading the available Hunspell dictionaries, they should be available for selection in the context menu in this text box.

    0_1524428904545_Add Norsk Languages.png


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.