Videos Fail To Play Much Of The Time!



  • What is the deal with Vivaldi not playing videos, totally hit or miss. Sometimes it will even play some videos on a site, yet other videos on the same site it will not. I find myself constantly switching back to Opera or Safari, just to watch a video.



  • Same issue here, Im very happy with all the functionality of the browser but have to switch to chrome to play videos. The will just not load in Vivaldi. Anyone have a clue whats going on here ?



  • Can confirm. HTML5 Videos and gifs not playing in v1.9 mac on youtube, twitter, imgur, reddit etc. (I don't use flash and therefore I have it disabled).

    This seems to happen a lot on each Vivaldi update. I'd suggest devs should have a mandatory HTML5 video/gif regression test for macOS before each release.



  • @Rascasse bug report filed


  • Moderator

    @Rascasse said in Videos Fail To Play Much Of The Time!:

    I'd suggest devs should have a mandatory HTML5 video/gif regression test for macOS

    They test on Mac, be sure.



  • Same issue here, having to switch all the time to watch videos.



  • Can confirm. I've been facing the same problem for a while. I usually switch to Chrome/Safari to watch the video if it does not play in Vivaldi.



  • @49616e Same here!



  • Same problem here!



  • @Gwen-Dragon Just updated to 1.9.818.49. HTML5 videos still not playing on twitter nor youtube.



  • Still happening under v1.9



  • @xyzzy solved this one for me. vivaldi://gpu showed that my gpu wasn't being used, so I went into vivaldi://flags and forced gpu use and h/w rasterisation. Videos play normally again, but as @xyzzy says, use at your own risk...

    "@Rascasse Re: your video issues, check vivaldi://gpu to see if your GPU has been blacklisted and hardware acceleration disabled. If so, videos should still play normally but apparently there's a bug in Vivaldi that needs to be squashed to get this working again on some systems.

    There's a flag to bypass the blacklist but I don't recommend using it because it can cause instability in Vivaldi; hardware acceleration will appear to work at first but at some point you'll hit a site that will either cause performance issues, instability, or breakage in the renderer."



  • @Rascasse I'm glad that things are working for you at the moment. However, I still can't stress enough that changing flags should always be done with caution. If you're running into any problems with Vivaldi, reverting any flags that you changed should be one of the first things that you do.

    By the way, I speak from experience. The GPU on my system was blacklisted as well and I too am having issues with video playback. Software rendering works fine in Chrome but not in Vivaldi. What I think is going on is that Vivaldi lacks the codecs for playing H.264 video internally and falls back on the system to do it, and something is breaking in the process. Enabling hardware acceleration "fixes" this but (for me) also causes serious issues with scrolling on some sites. Your level of breakage may vary.

    As for the GPU blacklist issue, keep in mind that your GPU (usually) got blacklisted for a good reason. If you do choose to override the blacklist, start first with the vivaldi://flags/#ignore-gpu-blacklist flag, and nothing else.

    The Chromium developers are in the process of reworking the GPU stack but I'm not tracking the changes. Their changes should be transparent but "stuff" happens. A few months ago, if you were running into strange rendering issues, turning hardware acceleration off was often a viable temporary workaround. (i.e. you effectively blacklisted your own system) Ideally, things should work fine both with hardware acceleration and with software-based rendering. Right now, some of us are in a sad state where neither is working properly.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.