As a developer, please help me with the cache



  • Daer all,

    I love Vivaldi for everything but since the begining i experienced a serious problem with the cache.
    As soon as i modify something in a CSS file, vivaldi changes nothing.
    It keeps eveything in cache for an undeterminated time and i am unable to see any change because vivaldi displays the cache. Only when i use it in private mode i can see the changement.
    Few monthes ago i was stuck with the same problem because i was unable to see the new favicon. it was impossible to see the new favicon.

    The problem also is that i don't want to clear everything, i would like to keep my history, my favorites, my passwords...
    I saw that we can clear some elements but idealy i just want no cache in order to see what's happening when i change a css, that all.

    I am desperate. I don't want cache i want live preview of what i am working on.
    Please, help me please, thank you.



  • Doesn’t Force Page Reload (Ctrl+Shift+R or Ctrl+F5) work for you?



  • I'm also a developer and have the same problem in all browsers except Opera12 , but usually only when dealing with localhost websites.
    My solve is I usually open the page I am working on in a private tab, With Vivaldi I open the page in a private window. Cache and history are not saved for the session so a reload always gets the latest version of the page and any attached assets (js css images etc)
    Hope this help.



  • @Dantesoft Thank you very much for the answer.
    I tried it and it works.
    Just it happend something special now, when i change a css element, i jus have to refresh the page and it works also but just before your trick it did not work.
    In order to be lear, before your trick, my page doesn't show the last modified css. Just after press ctrl + shift + r, the page showed the right css but now i just need to refresh the page to see any modifications...

    So, anyway i keep in my mind ctrl + shift + r.

    Thank you!



  • @sirjeff Thank you for your advices sirjeff!



  • If you are using a local webserver, disable all caching with a HTTP header.
    If you use local filesystem for development, use Open Developer Tools and disable cache in Network tab.



  • @Gwen-Dragon Thank you very much Gwen.



  • @flyeric777 Please tell, which of my answers helped you now?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.