Vertical tab bar behavior problem



  • Last couple of snaphots this thing still remains broken for me. I'm talking about VB-26867. Last time it was working in 1.8.770.9 and since then i'm still sitting on this version. It was really comfy, when scroll wheel was just scrolling the bar up and down without switching tabs. Can you guys tell me why you changed this behavior, please? I can make gifs, if you need.



  • Do you have a link for VB-26867?

    Have you tried changing the setting mentioned here?
    https://forum.vivaldi.net/topic/15410/vertical-tabs-switch-tabs-by-scrolling-autoscrolling-bug



  • @Furty Dev team resolved ot with "cannot reproduce" tag.
    I tried, but when you turn off scrolling, browser stops switching tabs when amout is low (like 10).
    And you can no longer switch tabs with rightclick+scroll, which is completely unusable for me.



  • So you got an email for your(?) bug report with "cannot reproduce" but no link for VB-26867? (i never reported a bug in Vivaldi)

    What means "browser stops switching tabs when amout is low"?



  • @Furty
    No, dev in russian part of forum told me that.
    It means that vivaldi doensn't switches tabs when you scroll on them with mouse wheel.


  • Moderator

    @S4dPanda I remember one user complaining about the bug that the tabs weren't switched on mouse scroll (while hovering the cursor above tabs) and it was fixed around 1.8 as far as I remember. If I get you right, you don't want to see this behavior? If so, then you can turn it off in Settings > Tabs > TAB FEATURES > Switch Tabs by Scrolling.



  • @pafflick There is still VB-14195
    And not exactly. It has two states: when amount of tabs is big and tab bar extends, and when it's not too much tabs. When you have < 30 tabs, it's okay, but when i have a lot of them, i need to scroll tab and i don't need tabs to be switched, it makes this completely unusable for me. In this case i can complain just like that user :)


  • Moderator

    @S4dPanda I don't know anything about the bug reports you've mentioned, sorry. I don't use vertical tabs, to begin with, plus the switching tabs by scrolling annoyed me so that I turned that option off in the settings. It actually affects two different features at once, so I also made a request to split those features.

    The fact is that someone else reported the issue with the tabs not switching on scrolling when they didn't fit on the screen (instead, the whole tab list was being scrolled). I remember seeing something about this being changed in one of the recent updates, but I didn't pay too much attention to it, as it doesn't affect me at all... I guess the user that I'm talking about wanted exactly the opposite of what you're asking for (hence the change in Vivaldi). It seems that - for now - the only workaround for you is to turn off the "Switch Tabs by Scrolling" feature.



  • @pafflick Yeah, yeah, thank you. I'll sit on 1.8.770.9 till it will be fixed.
    Also upvoted your request.


  • Moderator

    @S4dPanda said in Vertical tab bar behavior problem:

    I'll sit on 1.8.770.9 till it will be fixed.

    That may increase the exploit of your PC over security holes in old Chromium code base. Your risk. :bomb:



  • @Gwen-Dragon Bad news, but above mentioned tab bugs annoy me more.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.