[SOLVED] I can't open magnet links because I messed up and now I want to undo the changes



  • Hello. I was using Vivaldi to download something from some torrent trackers and I clicked a magnet link. But I messed up: when Vivaldi asked me if I wanted to launch the magnet link, I chose "no" and I had the "never ask again" checkbox checked.

    I want to undo that change and I don't know what to do. I've checked vivaldi://chrome/settings/content, but the handler list is empty. I can open magnet links fine in Firefox, IE11 and Egde, though.

    I also reinstalled µTorrent with no results. I don't know what else to do. I want to keep using Vivaldi, but if I can't fix this I'll have to go back to Firefox. Please help me.



  • Dunno if you tried to google for it, maybe this?
    https://www.maketecheasier.com/open-magnet-link-in-browser/



  • @iAN-CooG Been there, done that. And I still can't open magnet links with Vivaldi.



  • this is my registry, edit your user name and adapt your paths to your torrent client

    REGEDIT4
    
    [HKEY_CLASSES_ROOT\Magnet]
    @="Magnet URI"
    "URL Protocol"=""
    "Content Type"="application/x-magnet"
    
    [HKEY_CLASSES_ROOT\Magnet\Content Type]
    @="application/x-magnet"
    
    [HKEY_CLASSES_ROOT\Magnet\DefaultIcon]
    @="C:\\Users\\username\\AppData\\Roaming\\uTorrent\\maindoc.ico"
    
    [HKEY_CLASSES_ROOT\Magnet\shell]
    @="open"
    
    [HKEY_CLASSES_ROOT\Magnet\shell\open]
    
    [HKEY_CLASSES_ROOT\Magnet\shell\open\command]
    @="\"C:\\Users\\username\\AppData\\Roaming\\uTorrent\\uTorrent.exe\" \"%1\" /SHELLASSOC"
    
    

    the example magnet links on
    https://en.wikipedia.org/wiki/Magnet_URI_scheme
    works for me, opening utorrent when I click them in Vivaldi



  • another thing to check is
    "%localappdata%\Vivaldi\User Data\Default\Preferences"
    find in file "magnet": and see if it's set to false



  • Tried both things and still no luck.

    I ended up resetting my Vivaldi profile and the problem was gone.

    Thank you for your help. :D



  • Too bad, because it was just a matter of closing Vivaldi, hexediting the Preferences file and remove the "magnet" by replacing it with "xxxxxx", at next time a magnet url is clicked, Vivaldi would ask the question again, and then recreating the entry with "magnet":false

    For sure Vivaldi needs to get these settings more easily editable.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.