Commercial completion terribly annoying; please use the most used



  • When I type 'eb' into the address field, Vivaldi immediately completes that to 'ebags - Shop Bags and Accessories - Free Shipping – eBags.com'. It doesn't matter how many times I go to eBay, this is still what Vivaldi suggests. The same goes for some other completions.

    This is one of the most annoying things about this browser, and I'd love to be able to get rid of it. If there's already a way to disable this 'feature', let me know.



  • FAQ =)
    Check your bookmarks, it is there. Either remove the bookmarks you don't care about, or go in Settings/Address bar/Address auto complete/always prefer bookmarks and uncheck it.



  • @iAN-CooG said:

    Either remove the bookmarks you don't care about, or go in Settings/Address bar/Address auto complete/always prefer bookmarks and uncheck it.

    I have unchecked Always prefer bookmarks in vivaldi://settings/addressbar/ but it still happens.

    The workaround for me is to give nicknames to the desired bookmarks, e.g. eb or even e to that ebay.com bookmark.



  • Have you actually removed it from your bookmarks? and history while at it?
    Always prefer bookmarks has been bugged for some releases including 1.8 stable, where it was useless to untick it. Try latest snapshot where it should have been fixed.



  • @iAN-CooG said:

    Have you actually removed it from your bookmarks? and history while at it?

    That's the issue, exactly. One shouldn't have to delete history to get proper suggestions based on use.

    I eagerly await the fix in 1.9.



  • Thanks, everyone. I removed the setting and deleted all the useless bookmarks (of which for some reason I had two copies), and I'm using 1.9, and it works fine. Much better browsing experience. :)

    Do these stupid bookmarks come with Vivaldi? If so, it would be much better if they didn't.



  • @ET3D Vivaldi needs to generate income. Since we don't pay for the application upfront, this is done with preinstalled bookmarks and search engines instead. We can delete all of these easily, therefore this isn't really an issue.



  • Easy solution: delete predefined bookmarks in Bookmark Manager (open with Ctrl+B) after installing Vivaldi.
    Then you have no "commercial" urls ;)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.