Privacy error SSL



  • I really would like to see Vivaldi improving pages with insecure certificates. If you happen to load your home router login url for example which is an internal IP, its probably not signed. Sometimes the page works, sometimes Vivaldi gets stuck. When it works the normal Chrome page warning appears and you can exclude it but then it appears again. This is annoying. I would like to exclude a specific address for ever, so I don't have to see the warning again. Currently pages with insecure https certificates sometimes don't even display the warning, I have to keep reloading it until the warning appears.



  • Agree. Almost all our internal certs are self-signed and Vivaldi seems to have a problem even bringing up the warning to allow me to proceed.



  • I have all but given up on Opera because of the chronic certificate error warnings. i was hoping to see the issue resolved in Vivaldi but it seems to have the same issue. I recall a podcast with an Opera executive discussing the problem with certificates and the liability that might be incurred and a shift in policy regarding certificate acceptance. It was after this that the problem began. There is a certificate warning on the Vivaldi home page itself. There are no problem with certificates when using Firefox.
    It practically a deal killer to coin a phrase. Always having certificate errors can really make one paranoid. I'm seeing these errors on Windows XP.


  • Moderator

    Have never received a certificate warning on Vivaldi. Ever,



  • I believe that chromium-legacy browsers use Windows' own cert store for their certificates, whereas Olde Opera and Firefox both use custom stores belonging to each browser and updated from the browser makers' servers as needed. Consequently, a cert problem common to both New Opera and Vivaldi may lie within the OS's stored certs themselves. Because a cert has to reflect both the correct signing authorities and encryption schemes compatible with both the site server and the browser(s), anything that doesn't line up between the stored cert and what the site proposes can cause a problem. If there is something out-of-date or defective in your OS cert store, it can cause browser https problems on your system that other users of the same browsers, but up-to-date cert stores, don't see (hence @ayespy's comment).'

    I know that for Windows 7, Microsoft not too long ago issued a Windows KB update to enable automatic updating of the OS cert store; also, such cert auto-updating is already built-in to Window 8 and beyond. Because you're using WinXP, I wonder if you're dealing with an out-of-date OS cert store - particularly in light of numerous recent cert updates made necessary by protocol changes and deprecation resulting from exploits like Poodle, etc.



  • @foghorn:

    There are no problem with certificates when using Firefox.

    Fankly I have an opposite experience.

    I hate firefox and his nitpicking on obvious details. Like blocking the connection to vodafone.it because the cert was issued to vodafone.it and not to www.vodafone.it or because the page contains some non https elements.

    A warning, like the one provided by Vivaldi (and Opium) should be more than enough.



  • Hi,

    I'm having this issue also. I would like to be able to add self-signed certificates to an exception list so that I don't have to click click click.

    Also, I have Nginx HTTP password authorisation enabled on one site. On my first visit, after I entered my password, Vivaldi crashed. I've tried to reproduce, but it seems to be behaving now. Just though I would mention.

    Overall - great job! I've switched-over from Oepra/Firefox and liking it so far. Looking forward to the mail client!

    Thanks you to the team.



  • @Ayespy:

    Have never received a certificate warning on Vivaldi. Ever,

    We are talking about self signed certificates here.

    Example logging into your router or another system you own and is self signed:

    https://192.192.192.0

    All browsers display an invalid certificate which is correct, but let you proceed or remember the option. I actually hate how Chrome does it. Firefox at least gives you the choice to remember it and not ask again on every session.

    The problem is Vivaldi uses the default Chromium message page for this, which sucks, but the bug is that it does not appear every time. You need to switch tabs and go back to see it or reload the page, otherwise you only see a blank page. It also takes forever to even display this page. You cannot open the page until you see the security warning and can click the option but this does not always appear.



  • You need to switch tabs and go back to see it or reload the page, otherwise you only see a blank page. It also takes forever to even display this page. You cannot open the page until you see the security warning and can click the option but this does not always appear.

    This is my experience also.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.