Compton and vivaldi



  • Anyone here using compton with vivaldi, and if so, are you blocking vivaldi from becoming transparent. if so, how are you doing it? i used xprop and tried with a class, but it didnt work.



  • An option opacity-exclude does not exist in compton, but opacity-rule should do the job:

    inactive-opacity = 0.8;
    opacity-rule = [ "99:class_g = 'Vivaldi-snapshot'" ];
    


  • @WernerFP said in Compton and vivaldi:

    An option opacity-exclude does not exist in compton, but opacity-rule should do the job:

    inactive-opacity = 0.8;
    opacity-rule = [ "99:class_g = 'Vivaldi-snapshot'" ];
    

    Only works when on something that has vivaldi in the title...



  • @xeanto said in Compton and vivaldi:

    Only works when on something that has vivaldi in the title...

    That's strange. To do this with compton the rule would be:
    opacity-rule = [ "99:n:w:Vivaldi*" ];

    To exclude Vivaldi you can also use the window general class:
    opacity-rule = [ "99:g:w:Vivaldi*" ];
    or the exact name:
    opacity-rule = [ "99:g:e:'Vivaldi-snapshot'" ];
    or the instance with wildcard:
    opacity-rule = [ "99:i:w:crx_*" ];

    I think this option should be commented:
    #inactive-opacity-override = true;

    If the rules don't work it is probably not compton but another reason. Could it be that another WM-compositing runs at the same time?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.