Vivaldi 1.8.770.56 crashes on startup with Segfault



  • This is on Ubuntu 16.04 (Xenial) with kernel 4.4.0-72 under Gnome Classic.

    Crashes started today, after, I believe, Vivaldi was updated to build 1.8.770.56.

    Starting Vivaldi from the Application dock doesn't do anything.

    Starting it from the command line shows:

    $ vivaldi
    [7598:7598:0415/123832.219753:ERROR:child_thread_impl.cc(762)] Request for unknown Channel-associated interface: ui::mojom::GpuMain
    Segmentation fault (core dumped)
    $ vivaldi --version
    Vivaldi 1.8.770.56

    Any ideas about cause and remedy?

    Thanks in advance!



  • @wiewaldi2017

    1. Try to run;
      $> vivaldi --disable-gpu
      To see if it run.

    2. Vivaldi with clean profile.

    3. Check if libffmpeg.so not in main Vivaldi installation folder. I believe that also cause crash. It place already move three times since I use Vivaldi.



  • @dLeon -- thanks for the speedy reply.

    vivaldi --disable-gpu yelds the same result (segmentation fault), but this time without the explanation where it crashed.

    I'll try a reboot, and run it again.



  • @dLeon - libffmpeg is in place, it seems:

    1465304 Apr 7 16:55 /opt/vivaldi/lib/libffmpeg.so

    Interesting additional observation:
    First start after reboot works (started from cmd line this time), brings the same ui::mojom::GpuMain error message.
    Has forgotten its open Windows from previous session.

    Closing vivaldi, and then starting it again fails with segfault.

    Looks like something is not cleaning up after itself properly when terminating the app.

    Will try with clean profile now.



  • @wiewaldi2017 said in Vivaldi 1.8.770.56 crashes on startup with Segfault:

    /opt/vivaldi/lib/libffmpeg.so

    This fiele is always there after install of Vivaldi. And it does not force such crash.

    Do you run Vivaldi as root? That may cause problems with graphics driver and X server.

    Something in syslog or kernellog around crash?



  • @Gwen-Dragon - not running as root (and nothing changed on my side since the long time it worked flawlessly.)

    The culprit appears to be the bookmarks.

    Starting from a clean profile, adding everything, including extensions, worked fine up to the point where I included the bookmarks.

    Weird ...



  • Looks like bookmarks file is broken.

    The Bookmarks file is JSON format, you may open it in editor like Kate or gedit or Notepad++ or even vim. may be you can see some strange entries in there?
    Some editors have extension/plugins to view and select the JSON tree easily.

    Are you bookmarks secret, very private? Otherwise you could send a bug report to Vivaldi and add it as attachment in reply of mail.
    I may test it on Ubuntu and Debian and other testers may have Mint to test.


    How to do a bugreport for Vivaldi
    Report the bug at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    If you use any extensions please give information which ones you use.
    If you have a URL or a own testpage which can checked, add it to the bugreport.
    If you have own testcase files (HTML, CSS, JS etc.) add them to the confirmation mail you get after report.
    If you have a screenrecording video, you can attach it to give the developers a hint how this might happen or look like.
    You will get a bug confirmation mail and in a reply to this mail you can add more information and files as attachments for the testers and bug tracking team.

    Thanks in advance for helping us to make Vivaldi better!




  • @wiewaldi2017

    Check if libffmpeg.so not in main Vivaldi installation folder. I believe that also cause crash. It place already move three times since I use Vivaldi.

    I should give more explanation on that.

    /opt/vivaldi/lib/libffmpeg.so was Vivaldi default.

    Once upon of time :grin:, the helper script install special built libffmpeg.so to /opt/vivaldi(-snapshot) root folder. Somehow, it work without issue for sometime, even when the next generation script already move the placement to /usr/lib/chromium-browser. Until, it finally Segmentation Fault Chromium Vivaldi in Linux.

    Current script place libffmpeg.so to /home/[username]/.local/lib/vivaldi.
    I expect, it to avoid future trouble and or I think it's easier to maintain that file in user access able folder.



  • @Gwen-Dragon -- since I was able to start Vivaldi "once per boot sequence", even with the bookmarks in place, I could look a bit into the bookmarks, and noticed that they had a group of (some twenty-odd) empty, unnamed folders, below the folders that, since a few build, have a date/time name (instead of dumping "bookmark all open pages into the top level).

    I was able to remove those from within a running Vivaldi (and not having to go into a JSON capable editor).
    Since then, Vivaldi starts up (if a bit slow).

    Is there a limit on the size of the bookmark file? Mine's somewhere in the 25 MB range ...

    Thanks for your detailed help!



  • @wiewaldi2017 ... aaaaand ... it crashes again.

    I give up for today ...
    Maybe there is a tool to convert the JSON file to HTML so that I can at least refer to it indirectly.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.