Watching videos in Vivaldi are sometimes laggy



  • I love Vivaldi and has had no problems except for playing videos on various sites. Youtube is usually fine, but I have experienced slowdowns there aswell.
    Basically videos are very slow and it almost feels like the whole PC is slowing down. This is especially noticable when I play videos in fullscreen. I'm not really sure what to do here so any help is appreciated.

    Edit:
    I should probably tell you my specs:

    OS: Windows 10
    GPU: GTX 1070
    CPU: Core i7 6700k
    RAM: 16GB DDR4 (3200Mhz)

    Im using a 1440p / 144Hz monitor.



  • Have you tried enabling/disabling hardware acceleration? You'll find it here: vivaldi://chrome/settings/search#hardware. Generally, such a slowdown should not occur while playing videos. I'm writing this on a Tablet which has 1.33 GHz Intel Atom processor and only 2 GB of RAM (integrated GPU) and videos play relatively smooth in Vivaldi here.

    I believe you're not the first user of GTX1070 to report such issues with Vivaldi. Perhaps there is some conflict with nVidia drivers? Do you keep them up to date? (I don't keep mine but I don't have any problems with my GTX). Maybe you could try tweaking some settings in the nVidia Control Panel?



  • @pafflick
    First of all, thank you, your tip worked! I turned off hardware acceleration and there is no longer any lag.
    I also found out that flash player is the issue. Whenever Im on a site using the flash player my whole PC will just lag.
    Seems like for whatever reason, flash is using a lot of resources and slows down the PC. So turning off hardware acceleration prevents flash from using so many resources I guess.
    I really hate flash player but some websites im on still uses it so I got no option but to have it installed.
    Again, thank you so much. I've been struggeling with this issue for days but its finally fixed

    Edit: By the way, that link you sent did not work, but I did manage to find the option anyways.

    Edit2: The reason your link didn't work is because Vivaldi is in Norwegian for me so searching in English is not gonna work :P

    Edit3: Jeez, thats a lot of edits. Yes, my drivers are up to date. I guess Nvidia drivers dont run nice with flash player.



  • OK, I'm glad it worked. To open that link in Vivaldi you have to either copy&paste it or select to open it in a new tab. I forgot that this "search" in settings doesn't work for other languages, sorry about that. Good thing that you've found it anyway.

    I also hate Flash and I'm eagerly waiting for the day when I could finally wave goodbye to it. 馃槣 But it's not this day yet, I guess... 馃檮


  • Moderator

    NVidia drivers make sometimes troubles, most of the GT drivers are more optimized for gaming and less for multimedia.
    Drivers and GPU/hardware acceleration is almost a problem with video on Vivaldi (and i saw strange things with Chromium like browsers, too).


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.