Tabs will not saved after reboot



  • Hi All,

    For years i used firefox till last week i saw one article with vavaldi into it.
    After reading it i get enthusiastic and start to using vavaldi.

    Now my problem, i have always open a lot of tabs in my browser, but after a reboot all my tabs are gone :S.
    I try to install a addon for it ( tabs & restore ) but this one shutdown vavaldi when i want to reopen my tabs.

    By firefox my tabs always saved when i reboot, how i can do the same with vivaldi?

    I am running windows 7 home premium 64 bit.
    Thanks a lot for your feedback.

    Greetings remco



  • @oxzhor Hi oxzhor,

    when you go to Setings --> Startup --> in the section "Startup with" do you have "Last Session" enabled?
    You can reach the settings via "Alt + P" or via the vivaldibutton --> Tools --> Settings



  • @zaibon yes this is enabled.



  • @oxzhor
    Mmh I think there was a similar case like you experience - but can't remember if there was a solution to this.
    1.) What version of vivaldi do you use (you can look it up on vivaldi://about)
    2.) Do you use any kind of security software (adblocker, antivirus progs, etc?)

    In the meantime you can use the function to save sessions as a workaround.
    It will save all tabs that are open.

    • Press "F2"
    • Type Session
    • Select "Save Open Tabs as Session"
    • Give it a name and you're done
    • To load them it is the same way just select "Open Saved Sessions"


  • @zaibon said in Tabs will not saved after reboot:

    vivaldi://about

    Hi,

    Here the info:

    Vivaldi 1.8.770.56 (Stable channel) (32-bit)
    Revision e2cd2e0f9cc4bf56968f7869149c05302db06306
    OS Windows
    JavaScript V8 5.7.492.72
    Flash (Disabled)
    User Agent Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.138 Safari/537.36 Vivaldi/1.8.770.56
    Command Line "C:\Users\Remco\AppData\Local\Vivaldi\Application\vivaldi.exe" --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --mark-non-secure-as=show-non-secure-passwords-cc-ui --flag-switches-begin --flag-switches-end
    Executable Path C:\Users\Remco\AppData\Local\Vivaldi\Application\vivaldi.exe
    Profile Path C:\Users\Remco\AppData\Local\Vivaldi\User Data\Default
    Compiler MSVC 2015

    The addons i used are ABP, Tabs Banckup & Restore and Webwhatsapp.
    Thx for the F2 trick a add this now.


  • Moderator

    @oxzhor: The Tabs Backup and Restore Extension may be interfering. I recommend you try removing it entirely, re-starting, see if your tab behavior is normal and, if it is, install it again and see what happens. (Disabling/enabling may not have the same effect.)



  • Unfortunately, I'm having exactly the same problem. I'm using Vivaldi since almost 1 year without any problem but since the last few updates, I always lost my tabs (even the pinned tabs).

    Here's my info:

    Vivaldi 1.8.770.56 (Stable channel) (32-Bit)
    Überarbeitung e2cd2e0f9cc4bf56968f7869149c05302db06306
    Betriebssystem Windows
    JavaScript V8 5.7.492.72
    Flash (Deaktiviert)
    User-Agent Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.138 Safari/537.36 Vivaldi/1.8.770.56
    Befehlszeile "C:\Users\Tim\AppData\Local\Vivaldi\Application\vivaldi.exe" --no-startup-window /prefetch:5 --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --mark-non-secure-as=show-non-secure-passwords-cc-ui --flag-switches-begin --flag-switches-end
    Ausführbarer Pfad C:\Users\Tim\AppData\Local\Vivaldi\Application\vivaldi.exe
    Profilpfad C:\Users\Tim\AppData\Local\Vivaldi\User Data\Default
    Compiler MSVC 2015

    I've some addons installed but no addon that is related to the tab or session management.



  • Got exactly the same problem on one of 3 PCs that I'm using Vivalid on. I have uBlock and the Twitch extension installed.

    I did some investigation and I think I found out how to avoid the problem. Disable that Vivaldi starts in the background when the user logs in. You can do that by right clicking the tray icon.



  • Oke i found maybe the problem and that is valvaldi on windows 7
    On my notebook with windows 10 i not have the problem.



  • @oxzhor said in Tabs will not saved after reboot:

    Oke i found maybe the problem and that is valvaldi on windows 7
    On my notebook with windows 10 i not have the problem.

    I don't think that it has something to do with Windows 7 or 10 because I'm using Windows 10 and got the same issue.

    @ShadowIce said in Tabs will not saved after reboot:

    Got exactly the same problem on one of 3 PCs that I'm using Vivalid on. I have uBlock and the Twitch extension installed.

    I did some investigation and I think I found out how to avoid the problem. Disable that Vivaldi starts in the background when the user logs in. You can do that by right clicking the tray icon.

    That solved the issue, thanks!



  • @timvol said in Tabs will not saved after reboot:

    I don't think that it has something to do with Windows 7 or 10 because I'm using Windows 10 and got the same issue.

    @ShadowIce said in Tabs will not saved after reboot:

    Got exactly the same problem on one of 3 PCs that I'm using Vivalid on. I have uBlock and the Twitch extension installed.

    I did some investigation and I think I found out how to avoid the problem. Disable that Vivaldi starts in the background when the user logs in. You can do that by right clicking the tray icon.

    That solved the issue, thanks!

    That work for me to, i disable auto start via msconfig



  • @ShadowIce said in Tabs will not saved after reboot:

    I did some investigation and I think I found out how to avoid the problem. Disable that Vivaldi starts in the background when the user logs in. You can do that by right clicking the tray icon.

    I noticed also (using SysInternals autoruns) that Vivaldi registers itself to run at user logon. Does anybody know (out of curiosity) why it does that ? (maybe auto-update related ?)



  • Ok failed, it is not working, the problem is still there :S



  • @oxzhor

    I was able to fix this by disabling the extension Todoist, which I actually hadn't started using. This HAD been working prior to the update, however. I disabled all extensions, then enabled them one by one, opened some random pages, rebooted, and opened Vivaldi again. This appeared to be the culprit. Hope this helps!



  • @moebius286 Ok i disable all extensions and reboot a couple of times and the tabs are still there when i open vivaldi.
    Now i will enable them one by one to see which one give the problem.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.