Back Button not working properly on random occasions.



  • @cxw said in Back Button not working properly on random occasions.:

    @rafiki What was the bug number?

    VB-40030


  • Moderator

    To my knowledge, this bug is reproducible only if you have a specific hardware. All the mouses and trackpads that I use does not suffer from this bug. I believe that it's the case for the majority of HW and since it affects only a small fraction of users that is probably the main reason why it hasn't been fixed yet (but I'm just guessing).

    I don't have an access to the bug tracker, but you can ask here to find out whether the devs were able to at least reproduce the bug and if it hasn't been put away.


  • Moderator

    @rafiki Sadly our internal testers and devs could not reproduce this.
    As @pafflick said the issue may depend on pointer device hardware and its driver.



  • @gwen-dragon @pafflick Thanks both for the feedback. I guess that's it. As I mentioned in a post above I have assigned the button to be <Backspace> and I achieve the result required.


  • Moderator

    @rafiki Yeah, but that's just a workaround. Quite recently, another user came here with the same problem and I was unable to help him - we couldn't even find a workaround.

    So, I'd rather want that they would fix it - but for that, they'd have to reproduce this issue first. I hope they could get their hands on a device that has this bug - so I think it's a good idea to report this bug by stating explicitly on what kind of hardware this issue happens. @Gwen-Dragon maybe you have a better idea? 🤔


  • Moderator

    @pafflick said in Back Button not working properly on random occasions.:

    so I think it's a good idea to report this bug by stating explicitly on what kind of hardware this issue happens.

    Yes, giving the Vivaldi developers as much information about hardware may help.


  • Moderator

    @rafiki Please reply to the bug tracker mail of VB- and add some information about you meouse/trackback/touchpad and its seoftware/driver and OS you use.
    I will reopen the bug then.


  • Moderator

    @gwen-dragon Please add Acer V5-591G laptop to the affected devices if you can. Another user claims that it happens on ThinkPad E560. Windows 10 seems to even have native settings for this kind of devices, it looks like this:

    Win10 Settings
    I don't have a supported device to enable this in my settings, I got this screenshot from another user.



  • @gwen-dragon said in Back Button not working properly on random occasions.:

    @rafiki Please reply to the bug tracker mail of VB- and add some information about you meouse/trackback/touchpad and its seoftware/driver and OS you use.
    I will reopen the bug then.

    Thanks. Done,


  • Moderator

    @rafiki I reopend the bug.
    Let's hope some tester can check the issue with a Kensington trackball.



  • Just an addition: With the UltraNav Touchpad, the bug happens both when swiping (called "3Finger Flick" in settings) and when assigning "Browse backward one webpage" and "Browse forward one webpage" shortcuts to touchpad edges.

    Driver ist "Alps", version 8.216.1616.151, date 2016-09-16 with apfiltr.sys version 8,1,1616,521.

    I also tried assigning "Press the left arrow key" and "Press the right arrow key" to the edges to see, if these events get recognized twice, too. But they work as expected, moving the cursor only once in Vivaldi. Also when holding down the Alt key at the same, they do exactly what to expect.



  • @jtsn said in Back Button not working properly on random occasions.:

    I also tried assigning "Press the left arrow key" and "Press the right arrow key" to the edges to see, if these events get recognized twice, too. But they work as expected, moving the cursor only once in Vivaldi. Also when holding down the Alt key at the same, they do exactly what to expect.

    That tallys with my experience with the Kensington Wireless Trackball Mouse and reported here some time ago. The software setting for assigning "Back" (1 page) jumps back two pages. If I manually set up the same button in the software but for keystrokes Alt + left click the web pages jump back just one page as expected.



  • Hi all, I am having a similar issue (back action goes back multiple history points from one activation) and think my setup might help add to the debugging effort.

    I use strokesplus, a standalone mouse gesture program to make computer life with my built -in touchpad easier. The application is LUA-based. My normally used back gesture, which works in all other browsers and explorer windows, calls the virtual key VK_BROWSER_BACK as defined by microsoft here: https://docs.microsoft.com/en-us/windows/desktop/inputdev/virtual-key-codes

    Thanks for your help.



  • @brotherfunk Have you tried VK_BACK for backspace? Since this is the keyboard shortcut for going back in history this should theoretically work.



  • @luetage
    Thanks for your attention. I appreciate the effort.

    There are any number of workarounds that will work, but as the VK browser back works in almost all of my other applications (some really old freeware being the exceptions) as intended, changing the universal behavior of my back gesture would break a lot of others for the sake of one.

    I can also just use program specific gestures for vivaldi, but for efficiency's sake, I try to keep as many gestures under the universal umbrella as possible.

    The main intention of my post was to help the debuggers recreate and solve why this particular browser seems to treat certain software-based back functions differently than even chrome and chromium, where the VK works fine.

    Thanks again, BF



  • @brotherfunk said in Back Button not working properly on random occasions.:

    My normally used back gesture, which works in all other browsers and explorer windows, calls the virtual key VK_BROWSER_BACK as defined by microsoft here

    You found the culprit. Just to test this, I created a simple AutoHotKey script:

    ^!b:: Send {Browser_Back}
    

    which essentially maps the global hotkey Ctrl+Alt+B to VK_BROWSER_BACK. It works in any window (File Explorer, Opera etc.) as expected, but it goes two steps back in Vivaldi's history.

    So it's not a hardware issue at all. It seems to be bug in Vivaldi's window message processing. And it's even worse: Occasionally (!) it goes only one step back, but opens Vivaldi's menu at the same time. So on these occasions it didn't see VK_BROWSER_BACK twice, but the Alt key instead (which wasn't even meant for Vivaldi). To verify this, I remapped the hotkey from Ctrl+Alt+B to Ctrl+B and as a result it reliably goes back two steps in Vivaldi.

    Conclusion: Vivaldi processes VK_BROWSER_BACK twice and occasionally bugs out and processes keys meant for other applications.



  • This also happens with my laptop's Synaptics Touchpad using the built-in Windows 10 gestures.
    It's quite aggravating. Any ETA for a fix?



  • @JoeC00L It can only take another three years. 🤣



  • @jtsn It works fine on Windows 7 with a Intellimouse Explorer Classic and the (shitty) drivers that were included.

    I now mostly use Linux on the laptop so it's kinda fixed 😉 There are even Vivaldi dev-snapshots for Arch's AUR, I sure don't miss Windows 10.



  • same issue for me. Surface 4 Pro, Win10 (recently updated).
    3 finger swipe left/back (and only back) goes back 2 pages.
    edit: I use the built-in Win10 gestures...


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.