Bug(?) : Default search engine does not apply to page context menu



  • As said in the title. I changed the default search engine to DuckDuckGo. It is correctly changed in the top right search bar. When I search directly in the asdress bar it is OK, too. But when I select some text on a webpage, and right click,[b] it still says "Search with Google" (and [i]does[/i] search with Google)[/b]. I don't know if this is by design, but I would expect the default search engine to be applied there, too. [b]Edit : Add version info[/b] Vivaldi version : 1.0.98.2 OS : Windows 7 x64



  • This resembles Opera's behaviour. Is Vivaldi tied to Google (The Grandmaster of Censorship) the same way Opera is?



  • Same issue here, is there any update, or this is working as designed?(context menu option being 'Search Google for <search_criteria>')</search_criteria>



  • I think that Vivaldi Team simply forgot about this search option and that's why it's left like this - to search with Google. I hope they will fix it too.



  • This issue is stil standing, I am using

    Vivaldi 1.0.138.4 (Developer Build)
    Revision fc48a427ed86df9ef64bb99e590030e52fc95ed2
    OS Windows

    Would really love to have this fixed, as I tend to use it a lot.


  • Vivaldi Translator

    isn't it because of the content menu is used from Chromium and it's just not connected to Vivaldi's settings? I can see that like with translation or "private window" mode etc. which are Chromium things… (and not related to Vivaldi since there is no public version with private tabs and private windows)


  • Vivaldi Translator

    I filled like 5 bug reports reporting different Chromium context menus which should be trasnlated by us (not by Chromium team) and some that are not related to Vivaldi at all etc but cleaning is a work that no one wants to do it :D and this cleaning rule seems to apply on code cleaning as well… :)



  • Still set to "Search with Google", I am using TP3 …



  • This is a reported bug and will be fixed.

    Has nothing to do with "evil Googl" ;)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.