Flickering while opening a Flash based site on openSUSE leap 42.2



  • Every time, I tried to open a Flash based site; the page starts flickering. I am using Vivaldi(latest stable) on Fedora (25) and openSUSE. Flickering occurs only on openSUSE; everything seems to be fine on Fedora. I just wonder if it is because of the Flash player as openSUSE provides a distro based Flash player while in Fedora I'm using adobe-release repo. Example sites on which flickering occurs:

    http://www.youtube.com
    http://www.radio.gov.pk/player?1

    Did anyone else came across the issue? If so, what fix did you apply?



  • Some more details; I have both chrome and vivaldi installed; the problem occurs only on vivaldi and in a private window.
    Here are the details of my flash installation:

    Vivaldi: 1.8.770.54 (Stable channel) (64-bit)
    Revision: e2cd2e0f9cc4bf56968f7869149c05302db06306
    OS: Linux
    JavaScript: V8 5.7.492.72
    Flash: 25.0.0.127 /home/mahsan/.config/google-chrome/PepperFlash/25.0.0.127/libpepflashplayer.so
    Command Line: /usr/bin/vivaldi-stable --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --mark-non-secure-as=show-non-secure-passwords-cc-ui --flag-switches-begin --flag-switches-end

    A related question why vivaldi is saying 'show-non-secure-passwords-cc-ui in the command line arguments?



  • @ahsan

    All Flash player PPAPI plugin just same close source binary from Adobe. Some distro lucky enough to have maintainer(s) who repack it for repository ready.

    About flashing.
    Usually our advice start from, disable Hardware Acceleration at vivaldi://chrome/settings/search#hardware

    Youtube default not using Flash (plugin) anymore. They'll start with WEBM > H264 > FLASH. And Audio usually start from MP3 > MP4.

    For http://www.radio.gov.pk/player?1, is radio site? I can't find any videos there.
    Any of those radio just play fine here.


  • Vivaldi Team

    @ahsan I do not have that problem at all. I have tried on both Arch and the Ubuntu based KDE Neon. I have tried with both release and latest development build. I think this is an incompatibility issue with you graphics or it's driver. A detailed bug report at https://vivaldi.com/bugreport would be good with as much detail as possible. I see you have indicated you are using "Linux". I think we need more detail than that :)

    โ€‹//Christian - Thank you for using Vivaldi! :)



  • @ahsan Friend of mine also runs openSUSE Leap so I've a good reason to have him install vivaldi and test this for you on another machine but this may take a day or two.



  • I had the issue, the solution was simple:

    Put this in the address bar:

    vivaldi://chrome/settings/search#hardware

    Then unclick "Use Hardware acceleration when available and restart.

    Worked for me in Mint Cinnamon 18.1



  • Thanks everyone; disabling 'hardware acceleration' solves the issue. However, I am curious to know why do I need to disable the hardware acceleration and what's the impact of it.

    Searching through the chrome settings (chrome://settings/search#hardware) I found that hardware acceleration is checked. I'm curious to know why the flickering does not occur in chrome even though hardware acceleration is checked.



  • @zaibon Tested this yesterday and turning off hardware acceleration fixed it on leap.



  • @ahsan
    Some common reasons I could think of right now;

    • How hardware drivers was built. Like build parameters.
    • How libraries to build that driver built.
    • How is the hardware it self. Some monitor screen size seem cause glitch to Vivaldi. Or Video cards could cause flip, out of sync, or what ever.
    • The last, how the user software been built and thrown to real world problems above.

    I give high respect to people (developers) who actually have time to debug all of that.




Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.