Autocomplete in address bar makes no sense, suggests sites I've never been to over bookmarks.



  • Today, when connecting to Facebook, the first suggestion to pop up when I typed "f" into the address bar was ft.com, which is the Financial Times. I don't read Financial Times. Nobody in my house reads Financial Times. Hell, this is even a fresh (couple-day-old) install of Vivaldi, so it's not even like I've had time to screw it up yet. Needless to say, it's f*cking stupid to have what I can only assume is a sponsored result override my actual data, and if this is by design I'm going back to Chromium ASAP.


  • Moderator

    @eltimablo: Autocomplete is broken and being worked on.



  • When you've calmed down and got back some reasoning, just check your bookmarks and delete the ones that have been installed by Vivaldi on 1st installation. Yes, those are the only "sponsoring ads", if you really want to call them like this, you have in Vivaldi. And besides that, you can always check your settings and remove "always prefer bookmarks" in address bar setting for autocompletion. :rolling_eyes:



  • @iAN-CooG thanks for the suggestion. I found the bookmark. Didn't realize Vivaldi came with that many preconfigured bookmarks, since I'm used to Chromium which ships with nothing.

    @Ayespy is there a public bugtracker where I could follow the progress of the bug?


  • Moderator

    @eltimablo: The bugtracker is not public, but you may ask a Mod at any point. Right now, turning off "Always prefer bookmarks" doesn't always turn off bookmark pref (though deleting unwanted bookmarks keeps you from being directed to them), and where it was working pretty well for some releases to put your most-used or the domain root at the top of autocomplete results, it looks like a Chromium update broke that for us (thanks Chromium) and so that's being reconfigured to make better use of history and to otherwise truncate autocompletes for top-line results.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.