iPod Touch problems



  • Starting today, my iPod Touch has been having problems. I now can no longer download apps anymore and I just get a message instead saying unable to download app along with apps refusing to install and pausing. Apps also take a long time to download as well. I feel like giving up at this point and I don't know what to do. What should and can I do?



  • I decided to erase my iPod Touch once again. Sick and tired of dealing with the messages that would consistently pop up on the device.



  • Well, I don't have too much experience with Apple products, so I probably can't help you, sorry... I just wanted to share some thoughts of mine. 😜

    First of all, I'm into Windows OS and Microsoft products - practically every device* I use is based on either Windows 10, Windows Phone 8.1 or Windows Mobile 6.5 (yes, I still use an old WM phone). 😁 I'm also using a Windows 10 tablet and two of the best things about it are that it's actually a usual Windows PC (but really compact and with a touch screen) and the other thing is of course that I can use Vivaldi on it. 🤗

    * I have Android installed on my TV and I absolutely hate everything about that OS. I've tried to use Android phones for some time but I didn't like them either. I didn't get my hands on any iPhone nor iPad yet. I've tried iMac's and MacBook's, but I couldn't find any reason to switch over to MacOS environment...



  • @pafflick

    It's alright. I will just have to get help somewhere else. :P



  • @BradyBunchFan Or just wait - maybe another user also uses iPod Touch (not me though, sorry).



  • @TbGbe

    It's alright.



  • Done with my iPod Touch for good. Just simply waiting until I get a new one hopefully very soon.



  • Update: May be either next month or in June!



  • So, did you get a new one then. I have recently bought an iPod touch. Now reading to your post i need to know how long did it work really flawless. And did you not take help from Apple support?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.