Vivaldi 1.8 no longer respecting -user-data-dir switch?



  • After updating to 1.8 I noticed that my profile seemed to be reset to default. Looking at the issue further it appears the real issue is that Vivaldi is no longer respecting the -user-data-dir switch I've added to my shortcut. It has created and is using a new User Data directory in the default location, ignoring the existing one specified with the switch.

    I don't see anything about this in the 1.8 change log. Is anyone else experiencing this issue?


  • Vivaldi Translator



  • The update messed up your shortcut. You'll need to manually edit it.

    I corrected mine to this:

    C:\Users\manormonster\AppData\Local\Vivaldi\Application\vivaldi.exe --user-data-dir="C:\Users\manormonster\AppData\Local\Vivaldi\Work User Data"
    


  • Interesting. My problem was not the same as the one from that other thread. The path to the Vivaldi executable was fine, not doubled. But the example put me on the right track. I had only one dash at the beginning of the switch rather than two (i.e. -user-data-dir rather than --user-data-dir). Adding the second dash resolved the problem.

    This still seems like a strange issue, however. The existing shortcut, with just one dash, worked fine with previous versions of Vivaldi. And just to put the icing on the cake, the shortcut also has the -incognito flag (note the single dash), which continues to work correctly.


  • Vivaldi Translator

    @fxds
    Yes, it suppose to be two dash originally --.
    It's common in Unix~BSD~Linux command line.

    I think I encounter that kind of problem around 2 months ago from other user.
    It surprise me that that one dash - work all this time.
    I believe that's a bug in Chromium.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.