New update broke my second profile



  • At work I have two Vivaldi shortcuts. My work one is set up to point to a different directory "-user-data-dir="C:\Users\manormonster\AppData\Local\Vivaldi\Work User Data". This worked until I installed the new update today, now it gives this error:

    Failed To Create Data Directory
    Vivaldi cannot read and write to its data directory:
    C:\Users\manormonster\AppData\Local\VivaldiC:\Users\manormonster\AppData\Local\Vivaldi



  • I don't know how did you manage to get this far with that, but your startup parameter seems to be incorrect. It should look like this: --user-data-dir="C:\Users\manormonster\AppData\Local\Vivaldi\Work User Data"

    That worked for me at least. Tested in Vivaldi 1.8.770.50 / 1.8.770.46 (both 32-bit on Windows 10 x64).



  • That's how it's set. I just had a formatting issue in my original post. The problem is not with the parameter, as it's been working for months.



  • @ManOrMonster Then maybe try changing it to a relative path, like this one: --user-data-dir="Work User Data"?
    You could try it with or without the leading backslash. I can't test this specific case because I only use standalone installations and both seem to work fine in this matter.

    Another thing I noticed is that even though I use standalone installation, Vivaldi still creates some folders within the %localappdata% directory. Might have to report the bug for that one... 🤔



  • @pafflick Unfortunately that did not work.



  • @pafflick I figured it out. The path to the executable was completely messed up in the shortcut... I can only assume the new install did it, but don't know why it would have. The double path in the error was my clue: "C:\Users\manormonster\AppData\Local\VivaldiC:\Users\manormonster\AppData\Local\Vivaldi" I backed through the path field and saw it was in there twice. No idea why Vivaldi would edit an existing shortcut (or even if it could). Fixed that and it works again.



  • @ManOrMonster Thanks for sharing that - I was just trying to help someone else and it seems like the update messed up their shortcut too - they were unable to even launch the browser using their old shortcut. Looks like there is some problem with the update itself then...

    Nevertheless, I'm glad that it's working for you again. 👍


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.