Smooth Scrolling...Anything But Smooth!



  • Well I like Vivaldi, I have had zero success with it being smooth, in terms of scrolling very jerky unlike Safari or Opera, which is very smooth 100% of the time.I've researched this issue on the forum and it seems to be an ongoing problem. I really want to use Vivaldi but just can't, with such an annoying issue. Suggestions?



  • What is your problem? Does the site start jumping when you scroll? As in, it bridges wide margins of text when you only scrolled a little.



  • I'd say choppy, shaky, sometimes will skip margins. Also some sites seem to be worse then others.



  • Yeah, I had this problem too for a long time. The "smooth scrolling" setting in vivaldi://settings/webpages has nothing to do with it, although I have turned it on at the moment.

    I couldn't fix the problem, at one point I read that disabling hardware acceleration in chrome://settings helps, and I tried it out and it fixed the issue, but disabling acceleration is a bad idea, if you want to do anything graphics related on your browser -- eg watching a video, so that's not an option.

    At some point Vivaldi stopped skipping while scrolling, and I haven't found out why yet...



  • I thought it might be an extension however thats not it. Also I tried to turn Smooth Scrolling off under chrome://flags/#disable-smooth-scrolling based on some research, but that feature isn't available. Well I'm glad its behaving for you now, hopefully mine will correct itself soon.



  • @luetage said in Smooth Scrolling...Anything But Smooth!:

    Yeah, I had this problem too for a long time. The "smooth scrolling" setting in vivaldi://settings/webpages has nothing to do with it, although I have turned it on at the moment.

    Do you (or anyone) know what the Smooth Scrolling Vivaldi setting does anymore? On my MacBook Pro, the Chrome #smooth-scrolling flag says "Sorry, this experiment is not available on your platform." I don't know if the underlying Chrome/Chromium code is still active but if it is, and this setting is a backdoor to a Chrome flag that should not be messed with, then setting/unsetting it might have detrimental effects.

    Everything that I've read on the topic says that smooth scrolling in Chrome/Chromium should now "just work" and if it doesn't, it's a driver-related issue. The only other active flag (that I know of) related to scrolling is #disable-threaded-scrolling, which forces scroll events to be handled on the main thread.

    I've tried setting "Smooth Scrolling" in the past and it seemed to make Vivaldi's scrolling on my system more jerky, and it seemed to remain somewhat jerky after unsetting it too. Of course, this jerkiness could all be completely in my head. Regardless, I don't mess with this setting anymore and question whether or not the it should still exist in Vivaldi. If anyone can provide authoritative information on this, I would love to hear it.



  • Totally agree, the fixes within Chromium are turned of in Vivaldi. I like just about everything about Vivaldi, however the "smooth" scrolling on my MacBook and iMac, just does not work and makes scrolling very irritating with the jerky motion, to the point I cant use Vivaldi. Not sure if this is on their priority list to fix, however it should be!



  • Actually, with a clean, out-of-the-box Vivaldi install, scrolling (for me) is not bad at all. However, Chrome is better, but neither comes close to Safari's buttery-smooth perfection.



  • I also had this problem... Ended up with installing SmoothScroll... Its perfect for personalizing, but you have to do some trial and error until you get what you like, which I'm completely fine with... If anyone's interested, my settings are:

    Step size [px] 70
    Animation time [ms] 700
    Acceleration scale 5
    Acceleration delta [ms] 99
    Pulse Scale 7
    Arrow key step size [px] 50

    I've tried to emulate the firefox scroll... Hope this helps :grinning:



  • @xyzzy That's interesting information, I didn't realize this flag is disabled. I turned smooth scrolling off now, don't think it should make a difference though, if it isn't functional anyway.

    I just compared Vivaldi scroll with Safari, and I can't make out a difference with the mousewheel tbh.



  • I'm using both the built in trackpad and an external trackpad, and I assure you that there is no comparison with Safari. Safari is totally smooth, as well as Opera and Chrome, but Vivaldi is well not smooth, to say the least. Smooth Scrolling option has no affect whatsoever!



  • BTW tried the smooth scrolling extensions have no affect, at least on my end.
    Please fix it, so I can use Vivaldi, it's a great browser, however just can't use it with that "glitch."



  • @luetage Scrolling inputs on a typical scrollwheel mouse will be processed differently than "touch-based" devices like a trackpad or Apple's Magic Mouse where gestures have to be pre-processed.

    If you open three tabs with different types of content such as:
    https://forum.vivaldi.net/category/34/vivaldi-browser-for-mac
    https://forum.vivaldi.net/topic/15388/full-screen-video-bugs
    http://www.imdb.com

    ...and then scroll, you'll see subtle differences in scrolling performance between browsers, and what looks good to me may not look good to you and vice versa. Factors such as our system hardware and the quality of the GPU acceleration code, system load, etc. along with our own human perception biases all play into our quality evaluations.

    That's interesting information, I didn't realize this flag is disabled. I turned smooth scrolling off now, don't think it should make a difference though, if it isn't functional anyway.

    I can't confirm whether the code is or is not functional (or its potential side-effects) without actually looking at the code. There's also lots of dormant code in Chrome and there's no telling what can happen if you bring it into an active state. Chrome flags are not like normal browser settings and are "hidden" for a reason; they're emergency overrides and shouldn't be changed unless absolutely necessary.



  • @xyzzy Hi, I appreciate the technical jargon, and understand that trackpads and a mouse, may cause the browser to work differently, however if you want a great browser, it should just work. IMHO.



  • @OldHickory30 I agree. FYI, I don't work for Vivaldi; Vivaldi employees have a red Vivaldi Team badge next to their name. I just try to help people out here as best as I can.



  • And I really appreciate that, it just frustrating, Vivaldi has so many great features, yet I cannot use it for something so fundamental.



  • @OldHickory30 If you go to: vivaldi://gpu
    can you confirm whether or not hardware acceleration is being used, whether or not the GPU process was able to boot, or if the browser has reverted to software-based rendering?



  • @xyzzy Unfortunately I'm not sure how to do that. I did do a clean install of Vivaldi, so whatever it defaults too is how I have it configured.



  • @OldHickory30 Let me try again... try opening this link vivaldi://gpu in a new tab.



  • Thanks....Here you go.

    Graphics Feature Status
    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Hardware accelerated
    Rasterization: Hardware accelerated
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    VPx Video Decode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated



Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.