MP4 videos not played, opened links (GIF / YouTube) are not rendered



  • Hello,

    I will try to be as succinct as possible, seeing the weird problems I have... (sorry my English is not perfect)

    I have a Mac, macOS Sierra, version 10.12.3.

    I recently installed Vivalvi, maybe 2-3 days ago, and installed a few add-ons, uBlock Origin, HTTS Everywhere, Privacy Badger and Referer Control. But no fancy configuration in the settings, just some simples changes for the keyboard, tabs, ... That's all.

    I am registered on the site "put.io", with some MP4 uploaded. And I can't watch these video, player is stuck on "Loading". I contacted the Support, they can't reproduce the problem. I tried to :

    • Clear my cache, restart Vivaldi
    • Disable / Uninstall all my add-ons
    • Uninstall / Reinstall Vivaldi
    • Uninstall / Reinstall my antivirus Avast

    But the problem still appears. What is strange is that I can normally watch videos on YouTube or DailyMotion for example.
    Do you have an explanation ? A simple MP4 video, with a basic HTML5 player...

    Then, another problem for many sites, for example "choualbox.com".
    When I click on an GIF item (let's say, this one : https://choualbox.com/BwPZt), I see the GIF but it is not played/animated...

    If I click on the GIF, he is opened in a new tab, I can see Vivaldi loading the page but nothing is rendered except a grey background -__-' . I found a (really weird, and boring) workaround : in this tab (the last opened when I clicked on the GIF), I copy the URL, I open a new tab, I paste the URL, press Enter, and this time the GIF is rendered/played !

    This problem is exactly the same for YouTube. Embeded videos are not played, if I click the title of the video a new tab is opened but I can only see a grey background. I have to copy URL / new tab / paste URL / press Enter to watch the video.

    Again, for all these problems I tried to disable/uninstall my add-ons, but nothing change.

    I would appreciate any help for all this cr**, or maybe your browser is just not fully ready for the Web.



  • @dal87opx Maybe use the forum search and see if other people had the same issue.... And post your graphic details, chrome://gpu information if you have problems with videos.



  • 0_1490640469019_Vivaldi chrome gpu.png



  • No acceleration
    Disabled features: all
    should ring some bells.



  • Of course, for me when I see red text it is never a good thing.
    But this is not my job, I don't know what to do with these "warnings".



  • @dal87opx
    That screenshot looks awfully familiar.
    https://forum.vivaldi.net/topic/14605/persisting-issues-from-1-5-display-problems-intel-hd-radeon.
    Although, that one on Windows.



  • Hardware acceleration is disabled. Go to chrome://flags and enable "Override software rendering list" (first entry on the site), then restart, see if it fixes it. Do you have an igpu? Interestingly the information Isn't being provided in your screenshot, but the blacklist is probably your issue. It's pretty common, I have the same flag switched on my system. And it doesn't only concern Vivaldi, but all chromium browsers (depends on chromium version though).



  • Enabling the flag "ignore-gpu-blacklist" resolved all the problems previously enounced. See the new chrome://gpu details.

    @luetage, concerning your question "Do you have an igpu", I don't know. How can I check that?

    PS: I wanted to mark my post as resolved but I can't edit it anymore.



  • @dal87opx
    igpu = Intel GPU



  • No, it stands for integrated graphics processing unit. This means it is a part of your cpu -- not a dedicated graphics card. The cpu on modern macs is made by intel though.

    @dal87opx To check what graphics you have on board, you can click the apple icon on the top left of your screen and on "About this mac". In the overview the graphics should be listed, but to make really sure you can click on "System report" at the bottom -- this opens a new window and on the left you can select "Graphics/Displays". All information should be available there.



  • @luetage
    O, that one. :grin:



  • @luetage , here is my System Report. So yes I can see it's an "igpu" as you said.

    Intel HD Graphics 3000 :
    
      Jeu de composants :	Intel HD Graphics 3000
      Type :	Processeur graphique (GPU)
      Bus :	Intégré
      VRAM (dynamique, max.) :	512 Mo
      Fournisseur :	Intel (0x8086)
      Identifiant du périphérique :	0x0126
      Identifiant de révision :	0x0009
      Moniteurs :
    LCD couleur :
      Type de moniteur :	LCD
      Résolution :	1280 x 800
      Profondeur de pixels :	Couleurs 32 bits (ARGB8888)
      Moniteur principal :	Oui
      Miroir :	Désactivé
      Connecté :	Oui
      Rotation :	Géré
      Régler la luminosité automatiquement :	Non
    PLX2483H :
      Résolution :	1920 x 1080 @ 60 Hz
      Profondeur de pixels :	Couleurs 32 bits (ARGB8888)
      Numéro de série du moniteur :	1128041105393
      Miroir :	Désactivé
      Connecté :	Oui
      Rotation :	Géré
      Régler la luminosité automatiquement :	Non
    


  • @dal87opx For the MP4 problem, you might have a problem that is discussed more here, I made an extension that helps work around the problem (see the bottom of the thread)... I'm not going to pretend it is a fix though. I was able to see the GIF play on choualbox on my Mac with the extension, maybe give it a shot?



  • @chainlightning , as I said :

    Enabling the flag "ignore-gpu-blacklist" resolved all the problems



  • @dal87opx Sorry, missed that... That didn't resolve my issue, but happy to hear it did yours.



  • Thank you so much for the help, this also fixed my video problems!
    I posted this two times here before, but no one was able to help me.
    I think this should immediately be fixed by Vivaldi, since six updates this problem exists!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.