Youtube bug



  • Latest version 1.7.735.46 (Stable channel) (64-bit) can't play some youtube videos.

    Example:

    https://www.youtube.com/watch?v=n6ss8g5SIAM

    In any other browser it plays just fine.



  • Check if your hardware acceleration is functional in vivaldi://gpu
    In case it's not you can try and enable "Override software rendering list" in vivaldi://flags (first entry, enable then restart).



  • I tried enabling "Override software rendering list" and restarting, i also tried 1.8.770.44 (Official Build) (64-bit) but still no luck.

    Seems to be a codec/decoder problem: right clicking on "stats for nerds" shows non working video as mp4 with codec avc1.4d401f, working ones as webm with codec vp9

    here is my vivaldi://gpu

    Graphics Feature Status
    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Hardware accelerated
    Rasterization: Software only, hardware acceleration unavailable
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    VPx Video Decode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Unavailable
    Driver Bug Workarounds
    adjust_src_dst_region_for_blitframebuffer
    decode_encode_srgb_for_generatemipmap
    disable_framebuffer_cmaa
    disable_multimonitor_multisampling
    disable_overlay_ca_layers
    disable_post_sub_buffers_for_onscreen_surfaces
    get_frag_data_info_bug
    pack_parameters_workaround_with_pack_buffer
    regenerate_struct_names
    remove_invariant_and_centroid_for_essl3
    reset_base_mipmap_level_before_texstorage
    scalarize_vec_and_mat_constructor_args
    set_zero_level_before_generating_mipmap
    unfold_short_circuit_as_ternary_operation
    unpack_alignment_workaround_with_unpack_buffer
    use_intermediary_for_copy_texture_image
    use_unused_standard_shared_blocks
    Problems Detected
    Some GPUs on Mac can perform poorly with GPU rasterization. Disable all known AMD GPUs other than the R200, R300, and D series, which have been tested.: 613272, 614468
    Disabled Features: gpu_rasterization
    Don't allow ES3 on Mac core profile < 4.1: 295792
    Disabled Features: webgl2
    Multisampling is buggy on OSX when multiple monitors are connected: 237931
    Applied Workarounds: disable_multimonitor_multisampling
    Unfold short circuit on Mac OS X: 307751
    Applied Workarounds: unfold_short_circuit_as_ternary_operation
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    Mac drivers handle struct scopes incorrectly: 403957
    Applied Workarounds: regenerate_struct_names
    Screen flickers on 2009 iMacs: 543324
    Applied Workarounds: disable_post_sub_buffers_for_onscreen_surfaces, disable_overlay_ca_layers
    glGenerateMipmap fails if the zero texture level is not set on some Mac drivers: 560499
    Applied Workarounds: set_zero_level_before_generating_mipmap
    Pack parameters work incorrectly with pack buffer bound: 563714
    Applied Workarounds: pack_parameters_workaround_with_pack_buffer
    Alignment works incorrectly with unpack buffer bound: 563714
    Applied Workarounds: unpack_alignment_workaround_with_unpack_buffer
    copyTexImage2D fails when reading from IOSurface on multiple GPU types.: 581777
    Applied Workarounds: use_intermediary_for_copy_texture_image
    Limited enabling of Chromium GL_INTEL_framebuffer_CMAA: 535198
    Applied Workarounds: disable_framebuffer_cmaa
    glGetFragData{Location|Index} works incorrectly on Max: 638340
    Applied Workarounds: get_frag_data_info_bug
    glTexStorage* are buggy when base mipmap level is not 0: 640506
    Applied Workarounds: reset_base_mipmap_level_before_texstorage
    Decode and encode before generateMipmap for srgb format textures on macosx: 634519
    Applied Workarounds: decode_encode_srgb_for_generatemipmap
    Insert statements to reference all members in unused std140/shared blocks on Mac: 618464
    Applied Workarounds: use_unused_standard_shared_blocks
    adjust src/dst region if blitting pixels outside read framebuffer on Mac: 644740
    Applied Workarounds: adjust_src_dst_region_for_blitframebuffer
    Mac driver GL 4.1 requires invariant and centroid to match between shaders: 639760, 641129
    Applied Workarounds: remove_invariant_and_centroid_for_essl3
    Disable KHR_blend_equation_advanced until cc shaders are updated: 661715
    Version Information
    Data exported 3/27/2017, 9:48:56 AM
    Chrome version Chrome/57.0.2987.111
    Operating system Mac OS X 10.12.3
    Software rendering list version 12.13
    Driver bug list version 9.29
    ANGLE commit id unknown hash
    2D graphics backend Skia/57 e3917fd5ca950222facf027a73d95c8339bced54
    Command Line Args --always-authorize-plugins --disable-smooth-scrolling --disable-translate --enable-blink-features=ResizeObserver --mark-non-secure-as=show-non-secure-passwords-cc-ui --flag-switches-begin --flag-switches-end
    Driver Information
    Initialization time 5
    In-process GPU false
    Passthrough Command Decoder false
    Sandboxed true
    GPU0 VENDOR = 0x1002, DEVICE= 0x944a ACTIVE
    Optimus false
    AMD switchable false
    Driver vendor
    Driver version 10.2.12
    Driver date
    Pixel shader version 3.30
    Vertex shader version 3.30
    Max. MSAA samples 8
    Machine model name iMac
    Machine model version 11.1
    GL_VENDOR ATI Technologies Inc.
    GL_RENDERER ATI Radeon HD 4850 OpenGL Engine
    GL_VERSION 3.3 ATI-10.2.12
    GL_EXTENSIONS GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shading_language_include GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_vertex_type_2_10_10_10_rev GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
    Disabled Extensions GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent
    Window system binding vendor
    Window system binding version
    Window system binding extensions
    Direct rendering Yes
    Reset notification strategy 0x0000
    GPU process crash count 0
    Compositor Information
    Tile Update Mode Zero-copy
    Partial Raster Enabled
    GpuMemoryBuffers Status
    ATC Software only
    ATCIA Software only
    DXT1 Software only
    DXT5 Software only
    ETC1 Software only
    R_8 GPU_READ_CPU_READ_WRITE, GPU_READ_CPU_READ_WRITE_PERSISTENT
    RG_88 Software only
    BGR_565 Software only
    RGBA_4444 Software only
    RGBX_8888 Software only
    RGBA_8888 GPU_READ, SCANOUT
    BGRX_8888 GPU_READ, SCANOUT
    BGRA_8888 GPU_READ, SCANOUT, GPU_READ_CPU_READ_WRITE, GPU_READ_CPU_READ_WRITE_PERSISTENT
    YVU_420 Software only
    YUV_420_BIPLANAR GPU_READ_CPU_READ_WRITE, GPU_READ_CPU_READ_WRITE_PERSISTENT
    UYVY_422 GPU_READ_CPU_READ_WRITE, GPU_READ_CPU_READ_WRITE_PERSISTENT
    Log Messages
    [689:775:0327/094853.358868:ERROR:gpu_video_decode_accelerator.cc(375)] : HW video decode not available for profile h264 main
    [689:775:0327/094853.837945:ERROR:gpu_video_decode_accelerator.cc(375)] : HW video decode not available for profile h264 main



  • Yeah, seems to be a codec problem.
    Try this test site: https://testdrive-archive.azurewebsites.net/Graphics/VideoFormatSupport/Default.html

    I found one chromium issue on the subject from some time ago, the issue was closed and won't be fixed, because it concerns so few people.
    https://bugs.chromium.org/p/chromium/issues/detail?id=486311

    If this is the problem, the video should play if you disable the flag "Hardware-accelerated video decode" and restart.



  • I'v tried the test site and i can correctly play:

    H.264 high profile (HTML5 video)
    WebM (HTML5 video)
    H.264 baseline profile (HTML5 video)

    I've tried disabling "Hardware-accelerated video decode" but still no luck



  • @matteobass You should reset your flags now, since they do not work. You can still try with a clean profile, but it probably won't work. Quit Vivaldi, make a copy of default folder (eg to your desktop) located at username/library/application support/vivaldi so you have a backup, then delete the original folder. Then restart Vivaldi and try the video. You can switch back to your original default folder by quitting Vivaldi, deleting the new Default folder and copying the one you saved before back in.

    But yeah, I'm out of ideas at this point. You can always file a bug report.



  • i've opened a ticket.
    I'll write here the results

    Regards



  • @luetage said in Youtube bug:

    Check if your hardware acceleration is functional in vivaldi://gpu
    In case it's not you can try and enable "Override software rendering list" in vivaldi://flags (first entry, enable then restart).

    On a mid-2011 Mac Mini running a Core i7. I was having similar problems of certain YouTube videos simply never loading no matter what, tried this fix and it worked for me. Just wanted to give this as a thumbs-up for others experiencing this issue.



  • I'm having the same problem with codec avc 1.4d401f on 1.9.818.50 (Stable channel) (64-bit). I've tried the solutions in this thread, and I just want to note that this issue is still happening for some users.

    One of the many videos I can't play:

    https://www.youtube.com/watch?v=YHEifuLCSIY



  • same problem here :/



  • @Frederic_C If you tried to troubleshoot already, you can file a bugreport.
    Does the video work for you on chrome or opera btw.?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.