Tab font



  • Hello

    I use manjaro and latest kde why tab font is soo bad?

    alt text



  • @prodare
    What's this "bad" category? In Linux, bad or good is too wide.

    Sorry, need to ask first. Because that screenshot shows yours quiet good, even better than mine.

    It said, image was even downgraded by this forum.
    0_1490164098746_font_quality.png
    That after I use personal custom.css to change default "Ubuntu" or "sans-serif" to "Ubuntu Condensed". Notice, the smear at random places. While yours look clean.


    Linux/Debian amd64
    Vivaldi 1.8.770.32



  • tabs :) font is really really bad
    alt text

    vs

    chromium
    alt text

    I live vivaldi is crazy fast but my eyes hurt now.

    now I use noto sans fonts not are smoothed and thsi is problem how to enable.
    alt text



  • Really no one know how to fix this?



  • @prodare
    Not from user side I believe.

    This Antialiasing & Hinting need to be fix from inside.

    This's mine with Ubuntu Condensed font. Compare it with quality in LxPanel, same font.

    0_1490320266152_tab_font.png
    The quality probably downgraded by forum.



  • @dLeon
    I think yours is better :D please give me settings\config to check font\size.



  • @prodare
    I'm using custom.css to re-font (if that even a word) entire places.
    Info for custom.css:
    https://forum.vivaldi.net/post/79101

    usersytle:

    .tab-position.tab {
        font-family: 'Ubuntu Condensed', sans-serif;
        font-size: 12pt !important;
    }
    

    Just change font-family to your preferred font.
    For font size, you either could use/tweak it or just use Vivaldi default 11.5px.

    Because we're Linux, I set these fontconfig settings all over the places like;

    • Desktop Environment (DE) font settings. Easiest.
    • $HOME/.config/fontconfig/fonts.conf
    • $HOME/.config/gtk3-0/settings.ini
    • $HOME/.gtkrc-2.0
    • $HOME/.Xresources
    antialias: true
    rgba: rgb
    #lcdfilter: lcddefault
    hinting: true
    hintsyle:  hintfull
    autohint: true
    #dpi: 99
    

    For lcdfilter, it's by default usually lcddefault anyway.
    For dpi, our monitors are different. So tweak/test it on your side. Default 96 on mine, all time bad.

    It seem you're just using KDE DE, you probably only need to set all of those for KDE. KDE put the settings in its own sub-folder.
    The other settings only needed if we use Window Manager (WM).



  • Interesting I today I change monitor dell u2515 2k and....

    alt text

    and now is ok before I had 22" 1650x1080



  • @prodare
    Awesome.
    Seem it's called "UltraSharp" with real reason.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.