How to force my modem's Config/Setup page to let browser store login.



  • Hi. This is definitely not a Vivaldi fault, hence i chose to post this here not in the usual V browser sections. The same hassle manifests with Chromium & Firefox.

    Despite/even with flag set:
    "Force-saving of passwords Mac, Windows, Linux, Chrome OS, Android" [at least, in V & C],
    & even checking that it's not in the list of sites never to have their passwords saved [again, in V & C, not FF], my modem-router seems determined to prevent any browser from storing my login credentials for its setup UI.

    My previous modem allowed this, the one before that again not. What's going on here? / why can't i force it to do what i want? Is there a workaround for this pls?



  • Hi @Steffie
    My belkin router's config page allows password saving.
    Possibly for security the page code is stopping it.
    Can't help you with that but maybe the inspect tool will clue you in.



  • @CantankRus
    Just been playing around with importing passwords via a .csv file.
    I can import individual passwords and works here but whether or not your router page will grab the password I don't know.

    Goto vivaldi://flags/#password-import-export and enable.
    Create a router.csv file....

    name,url,username,password
    Router,http://192.168.2.1/cgi-bin/login.exe,router,#####
    

    Using the address of your login page in place of mine, and your password in place of ####

    Goto vivaldi://chrome/settings/search#pass and click on "Manage passwords" at the bottom.
    Import your router.csv file.
    This just adds to your existing passwords.

    With my page I then had to click in the password box and choose "router"0_1490067758730_056.jpg .



  • @CantankRus -- Hi & thanks. Having read your suggestion i did try this... but sadly i'm pretty ignorant about this stuff so i could not really make much sense of what i was seeing. Maybe the "answer" was right there in front of me [in Inspect], but if so i was unable to recognise it.



  • @CantankRus -- Well, i read this & thought "oh wow, that is genius!!" [so thank you for taking the time to help]. I enabled the pswds import & relaunched V. I created the file, but just a Kate text file -- given that CSV is usually [for me anyway] more typically associated with spreadsheets, should i instead have created an actual spreadsheet?

    I mimicked your sample exactly, except used my address [same as yours but for 1 not 2], used my modem's UserID instead of "router", & obviously used mine's pswd.

    Did the Import bizzo, but weirdly no new entry appeared in the list. Repeated it, but ditto. Relaunched V, but it had not then magically appeared in the list. Unsurprisingly therefore, my modem's config login page still did not cooperate.

    But i really do wonder why the Import itself seemed not to work?
    ....................................................................................
    Tower & Lappy = Maui 17.03 x64 Plasma 5.9.3.
    ....................................................................................



  • @Steffie
    Are you including name,url,username,password as the first line in the file?
    Then the second line contains your actual values separated by a comma.
    If the import works it will appear straight away.



  • @CantankRus -- Yes. Here's what said file looks like, censored a bit of course:

    name,url,username,password
    Router,http://192.168.1.1/cgi-bin/login.exe,username,password
    

    [MODEDIT] added 3 backtick for code fence. Please see bottom of http://commonmark.org/help/

    Damnit this forum editor keeps turning it into a url...

    As i said, it refused to import, & presumably my modem can't be blamed for that. It's weird.



  • @Steffie -- Oh dear, it's most certainly something dumb that i am doing, coz i just tried the Import in Chromium, & it also failed to do it. Gahhhhhhh, even the easy things are hard.



  • @Steffie
    I don't know then. :confused:
    I created a text file with gedit which is the equivalent of kate.
    Saving with or without a .csv extension didn't seem to matter.
    Even importing this exact test file works.

    name,url,username,password
    test,http://test.com,username,password
    

    0_1490078233104_057.jpg

    Maybe export your current passwords and compare structure.
    (PS: delete any plain text password files when finished).

    Also here in Ubuntu the passwords are stored in ~/.local/share/keyrings/login.keyring which may be different in kde. The keyring is unlocked when I manually I log in.



  • @CantankRus - Ah, i also tried Geddit [i prefer Kate, but have Geddit as well, just as fallback] but it also made no difference... this is just so strange.

    i've reached the point of giving up now [didn't bother trying the export & comparison].

    Many thanks all the same for your kind help.

    PS: FYI, in Plasma5, it's not keyring but kwallet, & as far as i understand the encrypted data for it is here; ~/.local/share/kwalletd/ .



  • As I hadn't used a KDE desktop in a long while I installed Maui 17.03.
    I had no problems importing my bookmarks from Ubuntu or importing single bookmark files and they all appeared in kwallet.
    I would check access using kwallet manager.
    Somethings not right. :upside_down:



  • @CantankRus -- Interesting [& i admire your sense of dedication / tenacity! :-) ]. As i said earlier i certainly must be doing something dumb, but i haven't yet sussed out what it is. Many hours ago i thought it might be FireJail causing the Import [highly implausible, but i was desperate] so i tested that hypothesis by launching Chromium "naked" [not in the FJ sandbox] & retried the import, which still ignored it... with that failure, i didn't even bother then also testing V "naked".

    Look, you've been great & i appreciate it, but don't waste any more time on it now.

    BTW, i wonder if you will like Maui... I do [left Mint 17.3 KDE4 for it last year].



  • Nah it's not tenacity...just idle time and I find it a challenge to solve things.
    On Maui though... I'm impressed with the overall look and feel.
    Slick applications overlay and dolphin looks classy.
    I've set Maui up as the default boot and I'll test for a while.



  • @CantankRus -- Re Maui -- YAY! See, i come here all helpless & sad, asking plaintive tech support help for esoteric inanities, when all the time my secret agenda is to recruit more converts for The M Cause. Muhahahaha...

    Dolphin is a magnificent file manager. Because of it, i just can't look at Mate's, Cinnamon's, Xfce's paltry equivalents even half-seriously, & as for f/m in Fedora etc... bleh! Dolphin is simply brilliant [make sure you activate split-window & all the Root Actions, for maximum utility].

    No doubt you're already on top of this, but make sure you activate the xenial-main & xenial-neon-main Repos. That way you'll still have the 16.04 LTS stable base, but get the Maui-Devs curated [inhouse tested b4 release] Neon Plasma rolling releases. It's a great combo. Oh, also if you want there's instructions in the blog/fora for invoking the 16.04.2 HWE package upgrade.

    That'll do, donkey, that'll do...


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.