Start Page- how to replace default with an extension such as FVD Speed dial



  • Vivaldi is pretty great, but this is annoying to be unable to replace the new tab speed dial with an extension of my choice. New page in VIVI takes much too long to create new speed dials with and doesn't sync to any other computers or browsers.



  • Go to:
    Settings --> Tabs --> scroll to "New Tab Page" --> select "Specific Page" --> type: chrome://newtab/

    There were some reports that this didn't work for everybody (don't know why) - but entering chrome-extension://dsfsdkfslkdfdkfdkhdkgdflkgsfd/newtab.html
    seemes to solve this problem.

    EDIT: You maybe need to restart vivaldi but I am not sure about this


  • Vivaldi Translator

    chrome://newtab as @zaibon mentioned would work.

    There's two place we could set this:

    • In Startup section. Which effect homepage.
    • In Tab section. Which effect Vivaldi new tab page.

    If you install/use any new tab page extension, you can set homepage to chrome://newtab & point one in Tab section to homepage.
    Yeah, I know, a bit run around.

    I think people seem only set either one of them & think their new tab page doesn't work.



  • @zaibon said in Start Page- how to replace default with an extension such as FVD Speed dial:

    type: chrome://newtab/

    HOLY COW, it worked. Thank so much



  • @zaibon Thank you thank you. Worked great. you da best!!



  • @texas_techy You're welcome ^^



  • Dam,
    upgrade to Vivaldi 1.8 broke my start page from working again.
    I made sure it was set correctly per the directions above. no luck.

    UPDATE! never mind, I got it to work . but required a new newtab/ url.



  • @texas_techy How exactly did you get this to work again?


  • Vivaldi Translator

    @ankos28
    Scroll to top of this thread a bit & check @zaibon first reply.



  • @dLeon That was working until the upgrade to version 1.8. No matter what i do now the Vivaldi Speed Dial opens with a new tab. I can't change it back to FVD Speed Dial


  • Vivaldi Translator

    @ankos28
    The OP (which @zaibon replied) was talking about the break on 1.8.xxx Snapshot. It's not new problem on 1.8.xxx stable only.

    About that;
    chrome-extension://dsfsdkfslkdfdkfdkhdkgdflkgsfd/newtab.html

    That's the extension ID.
    Double check if that the correct ID for FVD Speed Dial on your side.
    On me, FVD Speed Dial ID is llaficoajjainaijghjlofdfmbjpebpa

    After the breakage, now you could only put it in Settings > Tabs > New Tab Page.
    Insert the mentioned address to input box.

    Sample of FVD Speed Dials working in new tab (I tile it with settings page);
    0_1490967016184_fvd_working.png



  • @dLeon Perfect, that works. Thanks.
    Only problem left that i can't have FVD Speed Dial as my Start page anymore, but that's something i can live with


  • Moderator

    @ankos28 What do you mean by "Start Page"? In Vivaldi Settings "Start Page" refers to the built-in Speed Dial page (vivaldi://startpage).

    If you want to start the browser with the FVD Speed Dial extension's homepage opened, you have to add its URL in the "Startup Pages" field (it will show up after choosing the option "Startup with Specific Pages" in startup settings: vivaldi://settings/startup/).



  • After spending 2 hours in getting FVD to open in new tab for ME, by searching the net, and using all the suggestions found here, I almost just gave up. Then I compared the addresses here to the actual FVD Speed Dial page address, and found MY problem was, that the " # " was missing from the end of the address......
    chrome-extension://llaficoajjainaijghjlofdfmbjpebpa/newtab.html# ..... :) Extensions in bar now being movable, and this whole new tab fiasco finally being fixed, I can once again claim Vivaldi as my default browser. Thanks Vivaldi. :)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.